poj3164 Command Network(最小树形图)

Command Network
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 12893 Accepted: 3737

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy
/*
对poj无语啦,之前用有道题c++提交wa,g++ac,我就一直用g++提交,结果这道题g++wa,c++AC    poj的世界,渣渣不懂
第一道最小树形图题目,加油!!!
题目大意:所有的点事单向连通的,输入N,M,接着输入N个点的坐标,M表示M条边,输入M的关系,最小的权值,不连通,则输出poor snoopy 
Time:2014-9-2 17:51 
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define MAX 105
#define INF 2000000000

struct Point{
	double x,y;
}p[MAX];
struct Edge{
	int u,v;
	double w;
}edge[MAX*MAX];
double dis(Point a,Point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double ans,minIn[MAX];
int pre[MAX],vis[MAX],id[MAX];
bool directed_Mst(int root,int V,int E){
	while(1){
		for(int i=0;i<V;i++)
			minIn[i]=INF;
		
		for(int i=0;i<E;i++){//找最小入度边 
			int u=edge[i].u;int v=edge[i].v;
			if(edge[i].w<minIn[v]&&u!=v){//后边循环可能会有u==v 
				minIn[v]=edge[i].w;pre[v]=u; 
			} 
		}
		
		for(int i=0;i<V;i++){ //如果不是根,且无入度,则不连通 
			if(i==root) continue;
			if(minIn[i]==INF) return false;
		} 
		int cnt=0;
		memset(vis,-1,sizeof(vis));
		memset(id,-1,sizeof(id));
		minIn[root]=0;//将根的最小入度边置为0,否则会加上根的最小入度出错 
		for(int i=0;i<V;i++){//找环 
			ans+=minIn[i];//加上最小入度边 
			int v=i;
			while(vis[v]!=i&&id[v]==-1&&v!=root){//此处和下边if条件 id[v]==-1 写成id[i] 
				vis[v]=i;v=pre[v];//如果不是根,则找到环 
			}
			if(id[v]==-1&&v!=root){//如果是环,编号缩点 
				for(int u=pre[v];u!=v;u=pre[u]){
					id[u]=cnt;
				} 
				id[v]=cnt++;
			} 
		}
	
		if(cnt==0) break;//无环 
		for(int i=0;i<V;i++)
			if(id[i]==-1) id[i]=cnt++; 
		//建新图
		for(int i=0;i<E;i++){
			int u=edge[i].u;int v=edge[i].v;
			edge[i].u=id[u];
			edge[i].v=id[v];
			if(id[u]!=id[v])//不在同一个环中,权值减去最小入度 
				edge[i].w-=minIn[v]; 
		}
		root=id[root]; V=cnt; 
	}
	return true;
}
void solve(){
	int N,M;
	while(scanf("%d%d",&N,&M)!=EOF){
		for(int i=0;i<N;i++)
		scanf("%lf%lf",&p[i].x,&p[i].y);
		
		for(int i=0;i<M;i++){
			scanf("%d%d",&edge[i].u,&edge[i].v);
			edge[i].u--;edge[i].v--;
			if(edge[i].u!=edge[i].v)
			 	edge[i].w=dis(p[edge[i].u],p[edge[i].v]);
			else
				edge[i].w=INF; //去自环
		}
		ans=0;
		if(directed_Mst(0,N,M))
			printf("%.2lf\n",ans);
		else
			printf("poor snoopy\n");
	}
}
int main(){
	solve();
return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值