杭电1532 Drainage Ditches(前向星最大流)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9801    Accepted Submission(s): 4657


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
poj1273原题,郁闷的是,前向星竟然在poj超时。。。有点奇怪,网上有前向星的解法的。难道是我前向星代码出问题了?还是C++的问题了?
/*
前向星解法,,加油!!!
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<climits>
#include<algorithm>
using namespace std;
#define MAX 200
#define INF INT_MAX
struct Edge{
	int u,v,cap;
	int next;
	Edge(){}
	Edge(int u,int v,int cap,int next):u(u),v(v),cap(cap),next(next){};
}edge[MAX<<2];
int Num;
int head[MAX],d[MAX];
int N,M;
void Add(int u,int v,int cap){
	edge[Num]=Edge(u,v,cap,head[u]);
	head[u]=Num++;
	edge[Num]=Edge(v,u,0,head[v]);
	head[v]=Num++;
}
bool BFS(int S,int T){
	queue<int>q;
	memset(d,-1,sizeof(d));
	q.push(S);d[S]=0;
	while(!q.empty()){
		int u=q.front();q.pop();
		for(int i=head[u];~i;i=edge[i].next){
			int v=edge[i].v;
			if(edge[i].cap>0&&d[v]==-1){
				d[v]=d[u]+1;
				q.push(v);
			}
		}
	}
	return d[T]!=-1;
}
int DFS(int u,int cur_flow){
	if(u==N) return cur_flow;
	int temp=cur_flow;
	for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].v;
		if(edge[i].cap>0&&d[u]+1==d[v]){
			int flow=DFS(v,min(temp,edge[i].cap));
			temp-=flow;
			edge[i].cap-=flow;
			edge[i^1].cap+=flow;
		}
	}
	return cur_flow-temp;
}
int Dinic(int S,int T){
	int max_flow=0;
	while(BFS(S,T)){
		int t;
		while(t=DFS(S,INF)){
			max_flow+=t;
		}
	}
	return max_flow;
}
void Init(){
	Num=0;
	memset(head,-1,sizeof(head));
}
void solve(){
	while(scanf("%d%d",&M,&N)!=EOF){
		int u,v,c;
		Init();
		while(M--){
			scanf("%d%d%d",&u,&v,&c);
			Add(u,v,c);
		}
		printf("%d\n",Dinic(1,N)); 
	}
}
int main(){
	solve();
return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值