NYOJ349 Sorting It All Out(拓扑排序)

Sorting It All Out

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
输入
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
输出
For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

样例输入
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

样例输出
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
来源
POJ
/*
poj的 另一种各种拓扑排序
Time:2014-12-12
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=30;

int in[MAX],q[MAX];
int map[MAX][MAX];
int topSort(int n){
	int tempIN[MAX];
	for(int i=1;i<=n;i++)
		tempIN[i]=in[i];
	
	int numIN,pos,flag=1,k=0;
	for(int i=1;i<=n;i++){
		numIN=0;pos=0;
		for(int j=1;j<=n;j++){//每次找一个入度为0 的 
			if(tempIN[j]==0){
				pos=j;
				numIN++;
				//printf("%d ",pos); 
			}
		}
		//printf("%d  %d\n",pos,numIN);
		tempIN[pos]=-1; 
		if(numIN==0) return 0;
		if(numIN>1) flag=-1;//无序,后边可能出现环  故不能直接返回
			q[k++]=pos;	 
		for(int j=1;j<=n;j++){
			if(map[pos][j]){
				tempIN[j]--;	
			}
		} 
	}
	return flag;	
}
int main(){
	int n,m;
	char str[10];
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0)break;
		memset(in,0,sizeof(in));
		memset(map,0,sizeof(map));
		int flag,sign=0;
		for(int i=1;i<=m;i++){
			scanf("%s",str);
			int u=str[0]-'A'+1;
			int v=str[2]-'A'+1;
			map[u][v]=1;
			in[v]++;
			if(sign) continue;
			flag=topSort(n);
			if(flag==0){
				sign=1;
				printf("Inconsistency found after %d relations.\n",i);
			}else if(flag==1){
				sign=1;
				printf("Sorted sequence determined after %d relations: ",i);
				for(int j=0;j<n;j++)
					printf("%c",q[j]+'A'-1);
				puts(".");
			}
		}
		if(flag==-1){
			puts("Sorted sequence cannot be determined.");
		}
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值