poj3259 Wormholes(SPFA)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 32160 Accepted: 11680

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold
/*
数组开3000,小了,RE了一次。。。。
竟然忘了spfa了  汗……
想半天怎么判断回去时负数了,百度了一下,才发现直接判负环就行,有负环多循环上几次回去就行。此题有点郁闷是正边是双向的,负边是单向的。。。。。。。加油!!!
Time:2014-12-13 15:47
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int MAX=5555;
struct Edge{
	int v,w;
	int next;
}edge[MAX];
int head[MAX],EN;
int N;
bool vis[MAX];
int d[MAX],out[MAX];
void Add(int u,int v,int w){
	edge[EN].w=w; edge[EN].v=v;
	edge[EN].next=head[u];
	head[u]=EN++;
}
void Init(){
	EN=0;
	memset(head,-1,sizeof(head));
	memset(vis,0,sizeof(vis));
}
bool SPFA(){
	queue<int>q;
	for(int i=1;i<=N;i++){//所有点入队,再出队 
		q.push(i); vis[i]=true;
		d[i]=0; out[i]=0;
	}
	while(!q.empty()){
		int u=q.front(); q.pop();
		if(++out[u]>N) return false;//存在负环
			vis[u]=false;
		for(int i=head[u];~i;i=edge[i].next){
			int w=edge[i].w; int v=edge[i].v;
			if(d[v]>d[u]+w){
				d[v]=d[u]+w;
				if(!vis[v]){
					q.push(v);
					vis[v]=true;
				}
			}
		} 
	}
	return true;
}
int main(){
	int T;
	int M,W,u,v,w;
	scanf("%d",&T);
	while(T--){
		Init();
		scanf("%d%d%d",&N,&M,&W);
		while(M--){
			scanf("%d%d%d",&u,&v,&w);
			Add(u,v,w); Add(v,u,w);
		}
		while(W--){
			scanf("%d%d%d",&u,&v,&w);
			Add(u,v,-w);
		}
		if(SPFA())puts("NO");
		else puts("YES");	
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值