poj2356 Find a multiple(鸽巢原理)

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6302 Accepted: 2753 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

Ural Collegiate Programming Contest 1999
/*
听着很高大上的鸽巢原理,其实就是加起来的那几个数对x个数取余,因为那个余数是循环的,如果得到的那个已经得到过一次,再得到的时候显然中间的差值就是x的倍数。。如果出现输入的n个数出现0的时候就会有找不到的情况,否则n个数中一定会有某几个数之和是n的倍数
Time:2014-12-23 21:30
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=100000+10;
int main(){
    int sum,n;
    int a[MAX],mod[MAX];
    while(scanf("%d",&n)!=EOF){
        memset(mod,-1,sizeof(mod));
            sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++){
            sum+=a[i];
            if(sum%n==0){
                    printf("%d\n",i+1);//个数
                for(int j=0;j<=i;j++){
                    printf("%d\n",a[j]);
                }
                break;
            }
            if(mod[sum%n]!=-1){
                printf("%d\n",i-mod[sum%n]);
                for(int j=mod[sum%n]+1;j<=i;j++){
                    printf("%d\n",a[j]);
                }
                break;
            }
            mod[sum%n]=i;
        }
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值