poj3278 Catch That Cow(BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 49456 Accepted: 15497

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
/*
此题好崩溃。。。基础的广搜题。。。。一个上午,,,写了三种方式的代码,,一直错。。。。。群里有个孩子帮我看了一下,发现这个范围应该是<MAX,而不是k。可能会超出k的范围。。。。。。。。。。。。。。。。。。。。。。wa了十几次
Time:2014-12-29 14:01
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int MAX=200000+10;
struct Point{
    int pos;
    int steps;
};
int n,k;
bool vis[MAX];
queue<Point>q;
int main(){
        scanf("%d%d",&n,&k);
        Point cur,temp;
        memset(vis,0,sizeof(vis));
        cur.pos=n,cur.steps=0;
        while(!q.empty())q.pop();
        q.push(cur);vis[n]=true;
        while(!q.empty()){
            cur=q.front(); q.pop();

            //printf("pos=%d steps=%d\n",cur.pos,cur.steps);
            for(int i=0;i<3;i++){
                if(i==0)temp.pos=cur.pos<<1;
                else if(i==1)temp.pos=cur.pos+1;
                else temp.pos=cur.pos-1;
                if(temp.pos>=0&&temp.pos<MAX&&!vis[temp.pos]){
                    temp.steps=cur.steps+1;
                    vis[temp.pos]=true;
                    q.push(temp);
                }
                if(cur.pos==k){
                    printf("%d\n",cur.steps);
                    break;
                }
            }
        }
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值