POJ 3278 Catch That Cow(bfs)

Catch That Cow

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 61246

 

Accepted: 19124

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input

Line 1: Two space-separated integers: N and K

 

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

 

Sample Input

5 17

Sample Output

4

 

 

题意:农夫和牛在一条直线上,分别是n点和k点。农夫要抓住牛有两种方法靠近牛,一:从x位置到x+1或x-1位置,二:从x位置到2*x;  每种位移方式都耗一个单位时间。问农夫到达牛位置的最少时间。

 

刚开始用贪心做,直接wa了。换bfs加优先队列,无数次RE。最后bfs和普通队列过了。

 

代码如下:

 

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,k,ans,mark[100010];
struct node
{
	int x,step;
}a,temp;

int bfs()
{
	int i;
	a.x=n;
	a.step=0;
	queue<node>q;
	memset(mark,0,sizeof(mark));
	q.push(a);
	mark[a.x]=1;
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		temp=a;
		for(i=0;i<3;i++)
		{
			if(i==0)
				temp.x=a.x+1;
			else if(i==1)
				temp.x=a.x-1;
			else if(i==2)
				temp.x=a.x*2;
			temp.step=a.step+1;
			if(temp.x==k)
			   return temp.step;
			if(temp.x<0||temp.x>100000)
			  continue;
			if(!mark[temp.x])
			{
				mark[temp.x]=1;
				q.push(temp);
			}
		}
	}
	return -1;
}

int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
    {
    	if(n==k)
    	   printf("0\n");
    	else
    	{
    	    ans=bfs();
    	    printf("%d\n",ans);
    	}
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值