poj2253 Frogger(最短路变形)

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26934 Accepted: 8763

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

Ulm Local 1997
/*
。。。pojG++双精度度%.f,然后改了却把测试的输出数据数改错了,一直WA
加油!!!
Time:2015-1-4 15:10
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
#define eps 1e-6
#define INF 0x3f3f3f3f
const int MAX=220;
struct Point{
    double x,y;
}p[MAX];
double g[MAX][MAX];
double dis[MAX];
double get_dis(Point a,Point b){
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

void SPFA(int n){//求得是所有路中的最大距离的最小值
    bool vis[MAX];
    memset(vis,0,sizeof(vis));
    queue<double>q;
    while(!q.empty())q.pop();
    for(int i=1;i<=n;i++){
        dis[i]=INF;//初始化为g[1][i],
        //如果终点距离为最大,其他点就不进行更新了。如果是INF,将会更新其他点最后结果为2.00
        //不论几是终点都可以。,不太好理解。不如Floyd好理解
    }dis[1]=0;
    q.push(1);vis[1]=true;
    while(!q.empty()){
        int u=q.front();q.pop();
        vis[u]=false;
        for(int i=1;i<=n;i++){
            if(dis[i]>max(dis[u],g[u][i])){//这条路上最大的距离
                dis[i]=max(dis[u],g[u][i]);
               // printf("i=%d  u=%d\n",i,u);
                //printf("dis[i]=%lf dis[u]=%lf g[u][i]=%lf\n",dis[i],dis[u],g[u][i]);
                if(!vis[i]){
                    q.push(i);
                    vis[i]=true;
                }
            }
        }
    }
    printf("%.3lf\n\n",dis[2]);
}
int main(){
    int n;
    int nCase=1;
    while(scanf("%d",&n)!=EOF){
            if(n==0)break;
        memset(p,0,sizeof(p));
        memset(g,0,sizeof(g));
        for(int i=1;i<=n;i++){
            scanf("%lf %lf",&p[i].x,&p[i].y);
        }
        for(int i=1;i<=n;i++){
            for(int j=i;j<=n;j++){
                if(i==j)
                g[i][j]=0;
                else
                g[i][j]=g[j][i]=get_dis(p[i],p[j]);
            }
        }
        printf("Scenario #%d\n",nCase++);
        printf("Frog Distance = ");
        SPFA(n);/*
        for(int k=1;k<=n;k++){
            for(int i=1;i<n;i++){
                for(int j=i+1;j<=n;j++){
                    if(g[i][k]<g[i][j]&&g[k][j]<g[i][j]){
                        g[i][j]=g[j][i]=max(g[i][k],g[k][j]);
                    }
                }
            }
        }
        printf("%.3lf\n\n",g[1][2]);
        */
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值