hust 1010 The Minimum Length(KMP)

Time Limit: 1000MS Memory Limit: 131072KB 64bit IO Format: %lld & %llu

 Status

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd  efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7

Source

/*

刚开始没看懂题意,搜索了一下题意。
顺便刷一刷bin神的专题。。这里边的专题经典多了
Time:2015-3-26 16:42
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=1000000+10;
char str[MAX];
int nxt[MAX];
void Get_next(){
    int i,j;
    i=0;j=-1;
    nxt[0]=-1;
    while(str[i]){
        if(j==-1||str[i]==str[j]){
            i++;j++;
            nxt[i]=j;
        }else
            j=nxt[j];
    }
}
int main(){
    while(scanf("%s",str)!=EOF){
        Get_next();
        int len=strlen(str);
        printf("%d\n",len-nxt[len]);
    }
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值