sdut 面向对象程序设计上机练习九(对象指针)

面向对象程序设计上机练习九(对象指针)

Time Limit: 1000MS Memory limit: 65536K

题目描述

建立对象数组,内放5个学生数据(学号是字符串类型、成绩是整型),设立max函数,用指向对象的指针作函数参数,在max函数中找出5个学生中成绩最高者,并输出其学号和成绩。

输入

输入5个学生数据。

输出

输出5个学生中成绩最高者的学号和成绩。

示例输入

01 89
02 78
03 56
04 92
05 76

示例输出

04 92

来源

#include <iostream>

using namespace std;

class student
{
public:
    char no[100];
    int score;
};

student a[5];

void max(student *&p)
{
    int i;
    int max=a[0].score;
    for(i=1; i<5; i++)
    {
        if(a[i].score > max)
        {
            max=a[i].score;
            p = &a[i];
        }
    }
}

int main()
{
    int i;
    for(i=0; i<5; i++)
        cin>>a[i].no>>a[i].score;
        
    student *p=&a[0];
    max(p);
    
    cout<<p->no<<" "<<p->score<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值