trie树(uva11488)

Pre x goodness of a set string is length of longest common pre x*number of strings in the set. For
example the pre x goodness of the set f000,001,0011g is 6.You are given a set of binary strings. Find
the maximum pre x goodness among all possible subsets of these binary strings.
Input
First line of the input contains T ( 20) the number of test cases. Each of the test cases start with n
( 50000) the number of strings. Each of the next n lines contains a string containing only `0' and `1'.
Maximum length of each of these string is 200.
Output
For each test case output the maximum pre x goodness among all possible subsets of n binary strings.
Sample Input
4
4
0000
0001
10101
010
2
01010010101010101010
11010010101010101010
3
010101010101000010001010
010101010101000010001000
010101010101000010001010
5
01010101010100001010010010100101
01010101010100001010011010101010
00001010101010110101
0001010101011010101
00010101010101001
Sample Output
6
20
66
44

由于只出现0,1,于是建立一个字典树,每一次到达一个节点,就在这个节点加上深度,然后ans求解最大的节点附加值就可以了。注意初始化

#include<bits/stdc++.h>
#define maxnode 100000
using namespace std;
int n;

struct Trie
{
	int ch[maxnode][3];
	int val[maxnode];
	int sz=1,ans=0;
	void init(){sz=1;ans=0;memset(ch[0],0,sizeof(ch[0]));memset(val,0,sizeof(val));}
	
	int idx(char c){return c-'0';}
	
	void insert(char* s,int len)
	{
		int u=0;
		for(int i=0;i<len;i++)
		{
			int v=idx(s[i]);
			if(!ch[u][v])
			{
				memset(ch[sz],0,sizeof(ch[sz]));
				ch[u][v]=sz++;
			}
			u=ch[u][v];
			val[u]+=(i+1);
			ans=max(ans,val[u]);
		}
	}
	
};

struct Trie trie;
char s[maxnode];

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		trie.init();
		cin>>n;
		while(n--)
		{
			cin>>s;
			trie.insert(s,strlen(s));
		}
		cout<<trie.ans<<"\n";
	}
}

  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值