Consider three political parties. Assume h1 = 3, h2 = 4 and h3 = 8 where hi is the hartal parameter for party i ( i = 1, 2, 3). Now, we will simulate the behavior of these three parties for N = 14 days. One must always start the simulation on a Sunday and assume that there will be no hartals on weekly holidays (on Fridays and Saturdays).
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | |
Days | ||||||||||||||
Su | Mo | Tu | We | Th | Fr | Sa | Su | Mo | Tu | We | Th | Fr | Sa | |
Party 1 | x | x | x | x | ||||||||||
Party 2 | x | x | x | |||||||||||
Party 3 | x | |||||||||||||
Hartals | 1 | 2 | 3 | 4 | 5 |
The simulation above shows that there will be exactly 5 hartals (on days 3, 4, 8, 9 and 12) in 14 days. There will be no hartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.
In this problem, given the hartal parameters for several political parties and the value of N, your job is to determine the number of working days we lose in those N days.
Input
The first line of the input consists of a single integer T giving the number of test cases to follow.
The first line of each test case contains an integer N ( ) giving the number of days over which the simulation must be run. The next line contains another integer P ( ) representing the number of political parties in this case. The ith of the next Plines contains a positive integer hi (which will never be a multiple of 7) giving the hartal parameter for party i ( ).
Output
For each test case in the input output the number of working days we lose. Each output must be on a separate line.
Sample Input
2 14 3 3 4 8 100 4 12 15 25 40
Sample Output
5 15
代码:
#include<stdio.h>
#include<string.h>
int main()
{
int T;
scanf("%d",&T);
{
while(T--)
{
int a[3657] = {0};
int n,p,i,j;
scanf("%d%d",&n,&p);
for( i = 1; i <= p; i++)
{
int h;
scanf("%d",&h);
int k = 6;
j = 0;
while( j <= n)
{
j += h;
k = (k + h) % 7;
if( k != 5 && k != 6)
a[j] = 1;
}
}
int count = 0;
for( int t = 1; t <= n; t++)
{
if(a[t] == 1)
count++;
}
printf("%d\n",count);
}
}
return 0;
}
题意解析:
题意是说,罢工问题。T组测试数据,N表示一共天数,P表示party。。。然后是hi表示为罢工的天数,从Su开始,星期五,六不算,求在N天内罢工了多少天。。。