hartals——UVA 10050

本文介绍了一个关于政治党派罢工行为的模拟问题,通过设定罢工参数来预测特定时间内因罢工而损失的工作日数量。文章提供了一段C语言代码实现,并通过示例说明了如何排除周末计算实际罢工天数。
摘要由CSDN通过智能技术生成
A social research organization has determined a simple set of parameters to simulate the behavior of the political parties of our country. One of the parameters is a positive integer  h  (called the  hartal parameter ) that denotes the average number of days between two successive  hartals  (strikes) called by the corresponding party. Though the parameter is far too simple to be flawless, it can still be used to forecast the damages caused by  hartals . The following example will give you a clear idea:


Consider three political parties. Assume h1 = 3, h2 = 4 and h3 = 8 where hi is the hartal parameter for party i ( i = 1, 2, 3). Now, we will simulate the behavior of these three parties for N = 14 days. One must always start the simulation on a Sunday and assume that there will be no hartals on weekly holidays (on Fridays and Saturdays).


 1234567891011121314
Days              
 SuMoTuWeThFrSaSuMoTuWeThFrSa
Party 1  x  x  x  x  
Party 2   x   x   x  
Party 3       x      
Hartals  12   34  5  


The simulation above shows that there will be exactly 5 hartals (on days 3, 4, 8, 9 and 12) in 14 days. There will be no hartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.

In this problem, given the hartal parameters for several political parties and the value of N, your job is to determine the number of working days we lose in those N days.

Input 

The first line of the input consists of a single integer T giving the number of test cases to follow.

The first line of each test case contains an integer N ( $7 \le N \le 3650$) giving the number of days over which the simulation must be run. The next line contains another integer P ( $1 \le P \le 100$) representing the number of political parties in this case. The i­th of the next Plines contains a positive integer hi (which will never be a multiple of 7) giving the hartal parameter for party i ( $1 \le i \leP$).

Output 

For each test case in the input output the number of working days we lose. Each output must be on a separate line.

Sample Input 

2
14
3
3
4
8
100
4
12
15
25
40

Sample Output 

5
15

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int T;
	scanf("%d",&T);
	{
		while(T--)
		{
			int a[3657] = {0};
			int n,p,i,j;
			scanf("%d%d",&n,&p);
			for( i = 1; i <= p; i++)
			{
				int h;
				scanf("%d",&h);
				int k = 6;
				j = 0;
				while( j <= n)
				{
					j += h;
					k = (k + h) % 7;
					if( k != 5 && k != 6)
						a[j] = 1;
				}
			}
			int count = 0;
			for( int t = 1; t <= n; t++)
			{
				if(a[t] == 1)
					count++;
			}
				printf("%d\n",count);
			
		}
	}
		return 0;
}




题意解析:

题意是说,罢工问题。T组测试数据,N表示一共天数,P表示party。。。然后是hi表示为罢工的天数,从Su开始,星期五,六不算,求在N天内罢工了多少天。。。


【资源介绍】 1、该资源包括项目的全部源码,下载可以直接使用! 2、本项目适合作为计算机、数学、电子信息等专业的课程设计、期末大作业和毕设项目,也可以作为小白实战演练和初期项目立项演示的重要参考借鉴资料。 3、本资源作为“学习资料”如果需要实现其他功能,需要能看懂代码,并且热爱钻研和多多调试实践。 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip 图像数据处理工具+数据(帮助用户快速划分数据集并增强图像数据集。通过自动化数据处理流程,简化了深度学习项目的数据准备工作).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值