1sting

**规律是第i项等于i-1项和i-2项的和和斐波那契一样
注意因为长度太长所以long long也存不下来所以得用数组
Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output
The output contain n lines, each line output the number of result you can get .

Sample Input
3
1
11
11111

Sample Output
1
2
8

Author
z.jt**

#include<bits/stdc++.h>

using namespace std; 
struct node {
	int a[5000];
	int l;//记录数组的长度 
}temp[210];
void get_he(int s1[],int s2[],int l,int k){
	//求和 
	int jinwei=0;//进位 
	for(int i=0;i<l;i++){
		temp[k].a[i]=(s1[i]+s2[i]+jinwei)%10;
		jinwei=(s1[i]+s2[i]+jinwei)/10;
	}
	//加完了之后进位>0说明应该向最高位进位 
	if(jinwei>0){
		temp[k].a[l]=jinwei;
		l++;//这时候长度也得加1 
	}
	temp[k].l=l;
}
int main(){
	int T;
	temp[1].a[0]=1;
	temp[2].a[0]=2;
	temp[1].l=temp[2].l=1;
	for(int i=3;i<=200;i++){
	//打表 
	get_he(temp[i-1].a,temp[i-2].a,max(temp[i-1].l,temp[i-2].l),i);
	}
	scanf("%d",&T);
	while(T--){
		char str[210];
		scanf("%s",str);
		int l=strlen(str);
		for(int i=temp[l].l-1;i>=0;i--){
			printf("%d",temp[l].a[i]);
		}
		printf("\n");
		getchar();
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值