hdu 4090 GemAnd Prince

Problem Description
Nowadays princess Claire wants one more guard and posts the ads throughout the kingdom. For her unparalleled beauty, generality, goodness and other virtues, many people gather at the capital and apply for the position. Because princess Claire is very clever, she doesn't want a fool to be her guard. As Claire is clever, she invents a game to test the applicants. The game is described as follows.
The game begins with a rectangular board of n rows and m columns, containing n*m grids. Each grid is filled with a gem and each gem is covered by one color, denoted by a number.(as the following shows).





If a gem has the same color with another one, and shares the same corner or the same border with it, the two are considered to be adjacent. Two adjacent gems are said to be connective. And we define that if A and B are connective, B and C are connective, then A and C are connective, namely the adjacency is transitive. Each time we can choose a gem and pick up all of the gems connected to it, including itself, and get a score equal to the square of the number of the gems we pick this time(but to make the game more challenging, the number of gems to be picked each time must be equal or larger than three).Another rule is that if one gem is picked, all the gems above it(if there is any)fall down to fill its grid,and if there is one column containing no gems at all, all the columns at its right(also if there is any) move left to fill the column. These rules can be shown as follows.


As the picture [a] above,all the gems that has color 1 are connective. After we choose one of them to be picked, all the gems that are connected to it must also be picked together, as the picture [b] shows (here we use 0 to denote the holes generated by the absence of gems).
Then the rest gems fall, as shown in picture [c]. Then the rest gems move left, as shown in picture [d]. Because we picked six gems at this time, our score increases 6*6=36.And furthermore, because we cannot find another gem, which has at least three gems connected to it(including itself),to be picked, the game comes to an end.
Each applicant will face such a board and the one who gets the highest score will have the honor to serve princess Claire.
Aswmtjdsj also wants to serve for princess Claire. But he realizes that competing with so many people, even among whom there are powerful ACMers, apparently there is little chance to succeed. With the strong desire to be the lucky dog, Aswmtjdsj asks you for help. Can you help make his dream come true?
 

Input
There are no more than 15 test cases, separated by a blank line, end with EOF. Each case has n+1 lines, the first line of a case has three integers n, m, k (1<=n, m<=8, 1<=k<=6). Each of the next n lines contains m integers. The integer at (i+1)th line and jth column denotes the color of the gem at the grid (i, j), where the grid(1, 1) denotes the top left one, while the grid(n, m) is the lower right one. The integer in the grid is among [1, k].
 

Output
For each case you should output the highest score you can get in one single line.
 

Sample Input
  
  
3 3 3 1 1 3 1 2 1 1 1 2 5 4 3 2 2 3 3 1 1 3 3 3 2 2 2 3 1 1 1 3 1 2 2


Sample Output
  
  
36 103
dfs+bfs...
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
int n,m,ki;
int a[8][8],MAX;
int color[7];
int qq[8][8];
int to[8][2]={{1,0},{0,1},{-1,0},{0,-1},{1,1},{-1,-1},{1,-1},{-1,1}};
struct node
{
    int x,y;
};
queue<node>Q;
int getsum()
{
    int i,j,ans=0;
    memset(color,0,sizeof(color));
    for(i=0;i<n;i++)
        for(j=0;j<m;j++)
            if(a[i][j])   
             color[a[i][j]]++;
        
    for(i=0;i<=ki;i++)
        ans=ans+color[i]*color[i];
    return ans;
}
void change()
{
    int i,j,k;
    memset(qq,0,sizeof(qq));
    for(i=0;i<m;i++)
    {
        for(j=n-1,k=n-1;j>=0;j--)
            if(a[j][i]!=0)    
            qq[k--][i]=a[j][i];
    }
    memset(a,0,sizeof(a));
    for(i=0,k=0;i<m;i++)
    {
        for(j=0;j<n;j++) 
        if(qq[j][i]!=0)
        break;
        if(j==n)
        continue;
        for(j=n-1;j>=0;j--)
            a[j][k]=qq[j][i];
        k++;
    }
}
int bfs(int x,int y,int num,bool (*hash)[8])
{
    int i,gs=0;
    node t,cur;
    while(!Q.empty())
    {
        Q.pop();
    }
    t.x=x;
    t.y=y;
    Q.push(t);
    while(!Q.empty())
    {
        cur=Q.front();
        Q.pop();
        for(i=0;i<8;i++)
        {
            t=cur;
            t.x=t.x+to[i][0];
            t.y=t.y+to[i][1];
            if(t.x>=0&&t.x<n && t.y>=0&&t.y<m)
            {
                if(!hash[t.x][t.y]&&a[t.x][t.y]==num)
                {
                    gs++;
                    a[t.x][t.y]=0;
                    hash[t.x][t.y]=true;
                    Q.push(t);
                }
            }
        }
    }
    return gs;
}
void dfs(int now){

    if(getsum()+now<=MAX) 
    return;//第一个剪枝
    if(MAX<now) MAX=now;
    int i,j,num,lhxl=-1;
    int g[8][8];
    int color[7];
    bool hash[8][8];
    memset(hash,false,sizeof(hash));
    memcpy(g,a,sizeof(g));
    memset(color,0,sizeof(color));
    for(i=0;i<n;i++)
        for(j=0;j<m;j++)
            if(a[i][j]) color[a[i][j]]++;
    for(i=1;i<=ki;i++) if(color[i]>lhxl) lhxl=color[i];
    if(lhxl<3) 
    return;//two
    for(i=0;i<n;i++)
        for(j=0;j<m;j++)
        {
            if(!hash[i][j] && g[i][j]!=0)
            {
                memcpy(a,g,sizeof(a));
                num = bfs(i,j,g[i][j],hash);
                color[g[i][j]]-=num;
                if(num<3)continue;//three
                change();
                dfs(now+num*num);
            }
        }
}
int main()
{
    int i,j;
    while(scanf("%d %d %d",&n,&m,&ki)>0){
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
                scanf("%d",&a[i][j]);
        MAX=-1;
        dfs(0);
        printf("%d\n",MAX);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值