poj 2184 Cow Exhibition

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

01背包,因为有负值先加一个点pos,以此为原点然后分正负分别转移。以smart为体积,幽默感为价值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int n,pos;
int s[105],f[105],dp[200005];
int main()
{
    int i,j,sum;
    while(~scanf("%d",&n))
    {
        pos=100000;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s[i],&f[i]);
        }
        memset(dp,-inf,sizeof dp);
        dp[pos]=0;
        for(i=0;i<n;i++)
        {
            if(s[i]>0)
            {
                for(j=200000;j>=s[i];j--)
                {
                    if(dp[j-s[i]]>-inf)//减了之后不为负,从os开始
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
                }
            }
            else
            {
                for(j=0;j<=200000+s[i];j++)
                {
                    if(dp[j-s[i]]>-inf)
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
                }
            }

        }
        int ans=0;
        for(i=100000;i<=200000;i++)
        if(dp[i]>0&&dp[i]+i-100000>ans)//如果不为负且可变大
        ans=dp[i]+i-100000;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值