hdu 2639 Bone Collector II

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2

0

求第k大的。开始想的是加一个从大到小找第k大的值,为什么不对

增加一维表示体积为j时第k大的值。用两个数组分别储存加或不加的两种状态,合并的时候用的是归并的思想。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int n,v,k;
int va[105],vo[105],dp[1010][50];
int a[50],b[50];
int main()
{
    int t,i,j,x,y,z,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&v,&k);
        for(i=0;i<n;i++) scanf("%d",&va[i]);
        for(i=0;i<n;i++) scanf("%d",&vo[i]);
        memset(dp,0,sizeof dp);
        for(i=0;i<n;i++)
            for(j=v;j>=vo[i];j--)
            {
                for(r=1;r<=k;r++)
                {
                    a[r]=dp[j-vo[i]][r]+va[i];
                    b[r]=dp[j][r];
                }
                a[r]=-1,b[r]=-1;
                x=y=z=1;
                while(z<=k&&(a[x]!=-1||b[y]!=-1))
                {
                    if(a[x]>b[y])
                    dp[j][z]=a[x++];
                    else
                    dp[j][z]=b[y++];
                    if(dp[j][z]!=dp[j][z-1])
                    z++;
                }
            }
            printf("%d\n",dp[v][k]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值