第三周练习题目—二分法 影子的最大长度

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 137   Accepted Submission(s) : 48
Problem Description
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
 
 
 
 

 题目分析:

1)

此题已知H,h,D,求影子的长度

 由实际经验知,影子的变化分为两阶段    设ε 为此状态的临界点,  当X<ε 时,影子长度逐渐变大;x=ε 时,影子长度达到最大,此时影子末点到达墙角;x>ε 时,影子长度逐渐减小,直到人到达墙壁;

所以 这个影子长度图像为一个开口向下的抛物线

求抛物线的某一点(最大值点或最小值点),可以采用三分法

2)最后输出的坐标可以为任意一点,left  right mid mmid ,均可

  

代码如下:

#include<stdio.h>
#define eps 1e-9
double x,limit,H,h,D;


double f(double x)
{
if(x<limit)
return h*x/(H-h);
else
return D-x+H-H*D/x+h*D/x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf",&H,&h,&D);
limit=D-D*h/H;
double left=0.0,right=D;
double mid,mmid;
while(right-left>eps)
{
mid=(left+right)/2.0;
mmid=(mid+right)/2.0;
if(f(mid)>f(mmid))
{
right=mmid;
}
else
left=mid;         
}
printf("%.3lf\n",f(mmid));


}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值