Light Bulb (三分)

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

 

题意:给出灯的高度H,人的高度h,灯到墙的水平距离D,求人的最长的影子长度。

题解

人到灯的水平距离为x,影长有三种情况:

1. 影子恰好到墙,根据三角形相似,得到 x=D-D*h/H,则影长为 D*h/H;

2. 影子一部分在地上,一部分在墙上,根据三角形相似,得到影长为 D-x+H-D*(H-h)/x ;

3. 影子全部在墙上,此时影长为 D。

在这里只说三分法,公式法链接:https://blog.csdn.net/Baiyi_destroyer/article/details/79718020

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <stack>
#include <vector>
#define MAX 0x3f3f3f3f
#define LL long long
using namespace std;
const double eps = 1e-9;
double H,h,D;
double L(double x)
{
       return D-x+H-(H-h)*D/x;
}
double ans(double l,double r)                                               // 三分查找
{
       double mid,mmid;
       mid=(l+r)/2;
       mmid=(mid+r)/2;
       if(r-l<eps)
           return L(mid);
       return L(mid)>=L(mmid)?ans(l,mmid):ans(mid,r);    
}
int main()
{
       int c;
       cin >> c;
       while(c--)
       {
           cin >> H >> h >> D;
           printf("%.3lf\n",ans((H-h)*D/H,D));   
       }
       return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值