最短路(Bellman_ford) Currency Exchange

Currency Exchange

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 18
Problem Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
 

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
 

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
 

Sample Input
  
  
3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00
 

Sample Output
  
  
YES
 

题目大意:
   兑换钱币,判断是否可以获取额外的钱
题目分析:
   1)判断是否可以兑换额外的钱币,即判断该过程是否收敛,那么Bellman_ford 便是一个判断是否收敛的算法
   2 )首先进行n-1趟的松弛,在判断是否还会进行松弛操作,若是,则说明权值不收敛,及这是一个有收益的过程,可以不断获益
  3)注意赋初值时候的初值,memset(Sum,0,sizoof Sum);
         进行松弛是的条件:if(Sum[y]+eps<(Sum[x]-C[j])*R[j]) //若原先的Sum较小,进行松弛
                                            Sum[y]=(Sum[x]-C[j])*R[j];
   4)Dijistra() 算法和Bellman_ford算法的区别:Dijstra()侧重于对点进行操作,而Bellman_ford()侧重于对边进行操作一
     后者可以判断松弛过程是否收敛


#include<stdio.h>

#include<string.h>
#include<math.h>
#define maxn 1000
#define INF 0x3f3f3f3f
#define eps 1e-6
int n,m,s;
double v;
int U[2*maxn],V[2*maxn];
double R[2*maxn],C[2*maxn],Sum[2*maxn];
int  Bellman_ford()
{
    int i,j,x,y;
    memset(Sum,0,sizeof(Sum));
    Sum[s]=v;
    for(i=1;i<n;i++)//进行n-1次迭代
    {
     for(j=1;j<=2*m;j++)//检查每一条边
     {
         x=U[j];
         y=V[j];
         if(Sum[y]+eps<(Sum[x]-C[j])*R[j])
         {
             Sum[y]=(Sum[x]-C[j])*R[j];
    
         }
     }
    }
    for(j=1;j<=2*m;j++)
    {
        int x=U[j],y=V[j];
        if(Sum[y]<(Sum[x]-C[j])*R[j])//说明不是权值收敛的
        {
         return 1;
        }
    }
    return 0;

}


int main()
{
    int i,a,b;
    double Rab,Cab,Rba,Cba;
   while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
   {
    for(i=1;i<=m;i++)
    {
        scanf("%d%d%lf%lf%lf%lf",&a,&b,&Rab,&Cab,&Rba,&Cba);
        U[2*i-1]=a,V[2*i-1]=b,R[2*i-1]=Rab,C[2*i-1]=Cab;
        U[2*i]=b,V[2*i]=a,R[2*i]=Rba,C[2*i]=Cba;
    }    
  if(Bellman_ford())
      printf("YES\n");
  else
      printf("NO\n");
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值