HDU2506 Tiling (高精度+递推)

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251	
分析: 手写可以写出前三项 分别为 1,3,5;
从第四项开始 我们可以发现 
假设已经求得了 长度为n-1 的方法数,那么要铺满n,只有一种方法,用1*2
假设已经求得了 长度为n-2 的方法数,那么要铺满n,有三种方法,用1*2,1*1(2);
由于n-1的时候已经包括了n-2的时候 所以
和起来的公式为: a[n]=a[n-1]+2*a[n-2];
数据比较大,需要用高精度进行处理
代码如下:
#include <iostream>
#include <cstring>
using namespace std;

void Bigadd(char a[],char b[],char c[])
{
    int n=strlen(a);
    int m=strlen(b);
    char temp;
    int i,j,e,d;
    for(i=0; i<m/2; i++)
    {
        temp=b[i];
        b[i]=b[m-1-i];
        b[m-1-i]=temp;
    }
    for(i=0; i<n/2; i++)
    {
        temp=a[i];
        a[i]=a[n-1-i];
        a[n-1-i]=temp;
    }
        d=0;
        e=0;
    for(i=0;i<n&&i<m;i++)
    {
        d=a[i]-'0'+b[i]-'0'+e;
        c[i]=d%10+'0';
        e=d/10;
    }
    if(i==m)
    {
        for(;i<n;i++)
        {
            d=a[i]-'0'+e;
            c[i]=d%10+'0';
            e=d/10;
        }
    }
    if(i==n)
    {
        for(;i<m;i++)
        {
            d=b[i]-'0'+e;
            c[i]=d%10+'0';
            e=d/10;
        }
    }
    if(e)
        c[i++]=e+'0';
    int t=i;
    for(i=0; i<t/2; i++)
    {
        temp=c[i];
        c[i]=c[t-1-i];
        c[t-1-i]=temp;
    }
    for(i=0; i<m/2; i++)
    {
        temp=b[i];
        b[i]=b[m-1-i];
        b[m-1-i]=temp;
    }
    for(i=0; i<n/2; i++)
    {
        temp=a[i];
        a[i]=a[n-1-i];
        a[n-1-i]=temp;
    }
}
int main(){
    int n;
    while(cin>>n){
        char a1[3000]="1";
        char a2[3000]="3";
        char a3[3000]="5";
        char tmp1[3000],tmp3[3000],tmp[3000];
        for(int i=4;i<=n;i++){
            memset(tmp1,0,sizeof(tmp1));
            memset(tmp3,0,sizeof(tmp3));
            strcpy(tmp,a2);
            Bigadd(a2,tmp,tmp1);
            Bigadd(a3,tmp1,tmp3);
            strcpy(a2,a3);
            strcpy(a3,tmp3);
        }
        if(n==1||n==0){
            cout<<"1"<<endl;
            continue;
        }
        if(n==2){
            cout<<"3"<<endl;
            continue;
        }
        cout<<a3<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值