poj2506 大数递推

8 篇文章 0 订阅
4 篇文章 0 订阅
Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8205 Accepted: 3974

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14

递推过程:
首先最左边的(右边) 的状态是一根竖着的时候 : 由f(n-1)组成;
   状态是两根横着的时候 f(n-2)组成;
  状态是一个2*2的木棍时候 由f(n-2)组成:

Fn=F(n-1)+2*F(n-2);
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int a[300][200];
    memset(a,0,sizeof(a));
    a[0][0]=1;
    a[1][0]=1;
    a[2][0]=3;
    for(int i=3; i<=250; i++)
    {
        for(int j=0; j<=100; j++)
        {
            a[i][j]+=(a[i-1][j]+a[i-2][j]+a[i-2][j]);
            if(a[i][j]>=10)
            {
                int t=a[i][j];
                a[i][j]%=10;
                a[i][j+1]+=t/10;
            }
        }
    }
    int n;
    while(cin>>n)
    {
        if(n==0)
            cout<<1<<endl;
        else
        {
            int i=100;
            while(!a[n][i])
            {
                i--;
            }
            for(int j=i; j>=0; j--)
                cout<<a[n][j];
            cout<<endl;
        }

    }
}
/*
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
    public static void main(String[] args)
    {
       Scanner cin = new Scanner ( System.in );
       BigInteger arr[]=new BigInteger[300];
       arr[1]=BigInteger.ONE;
        arr[0]=BigInteger.ONE;
       arr[2]=BigInteger.valueOf(3);
       arr[3]=BigInteger.valueOf(5);
       for(int i=4;i<=270;i++){
    	   arr[i]=arr[i-2].multiply(BigInteger.valueOf(2));
    	   arr[i]=arr[i].add(arr[i-1]);
       }
    	int t;
       while(cin.hasNext()==true){
    	   t=cin.nextInt();
    	   System.out.println(arr[t].toString());    	   
       }
    }
}

*/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值