HDU2689 Sort it (树状数组求逆序数)

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
  
  
3 1 2 3 4 4 3 2 1
 

Sample Output
  
  
0 6

在一个排列中,如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个逆序。一个排列中逆序的总数就称为这个排列的逆序数。逆序数为偶数的排列称为偶排列,逆序数为奇数的排列称为奇排列。如2 4 3 1中,(2,1),(4,3),(4,1),(3,1)是逆序,逆序数是4,为偶排列。

也是就说,对于n个不同的元素,先规定各元素之间有一个标准次序(例如n个不同的自然数,可规定从小到大为标准次序),于是在这n个元素的任一排列中,当某两个元素的先后次序与标准次序不同时,就说有1个逆序。一个排列中所有逆序总数叫做这个排列的逆序数。

如图14-1所示,用树状数组求逆序数时,数组A代表数字i是否在序列中出现过,如果数组i已经存在于序列中,则A[i]=1,否则A[i]=0,此时Query(i)返回值为在序列中比数字i小的元素的个数,假设序列中第i个元素的值为a,那么前i个元素中比i大的元素的个数为i-Query(a),逆序数的求法也就显而易见了。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn =1010;

int tree[maxn],n;

int lowbit(int x){
    return x&(-x);
}

void update(int x,int y){
    while(x<=n){
        tree[x]+=y;
        x+=lowbit(x);
    }
}

int query(int x){
    int sum=0;
    while(x>0){
        sum+=tree[x];
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    while(cin>>n){
        memset(tree,0,sizeof(tree));
        int a,ans=0;
        for(int i=1;i<=n;i++){
            cin>>a;
            update(a,1);
            ans+=i-query(a);
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值