POJ—2828—Buy_Tickets—【数据结构】【线段树】【单点更新】

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 14512 Accepted: 7247

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posiand Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243




思路:
先站队的都不是固定的,随时可能因为被插队,未知发生变化...而越靠后来的,位置越不容易变换...

所以就倒着来...倒着一个一个来,反而都是一站一个准,不会再变换...


样例1中正序是0112   , 可以想到,出现一个数字x,则它前面一定有 0,1,...x-1,x (x可能有可能没有)
所以倒序 2110, 取一个数字x,则前面要空出x个位子(因为下标从0开始,所以正好是x个,如果下标从1开始,就要x-1个位子)

线段树初始化:叶子节点均为1,非叶子结点为两个子节点的和,代表范围内的位子数
每次到达一个节点,先和左子树比较,如果剩余空位 大于(没有等于) 所需空位,往左;反之往右


#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;

const int MAXN=200100;
int num[MAXN<<2];
int ans[MAXN];

typedef struct
{
    int pos;
    int value;
}Unit;
Unit tmp[MAXN];

void PushUp(int ret)
{
    num[ret]=num[ret<<1]+num[ret<<1|1];
}

void BuildTree(int left,int right,int ret)
{
    if(left==right)
    {
        num[ret]=1;
        return ;
    }
    int mid=(left+right)>>1;
    BuildTree(left,mid,ret<<1);
    BuildTree(mid+1,right,ret<<1|1);
    PushUp(ret);
}

void Update(int pos,int value,int left,int right,int ret)
{
    if(left==right)
    {
        num[ret]=0;
        ans[left]=value;
        return ;
    }
    int mid=(left+right)>>1;
    if(num[ret<<1]>pos)
        Update(pos,value,left,mid,ret<<1);
    else
        Update(pos-num[ret<<1],value,mid+1,right,ret<<1|1);
    PushUp(ret);
}

int main()
{
    freopen("2828.in","r",stdin);
//    freopen("2828.out","w",stdout);
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        BuildTree(0,N-1,1);
        for(int i=0;i<N;i++)
            scanf("%d%d",&tmp[i].pos,&tmp[i].value);
        for(int i=N-1;i>=0;i--)
            Update(tmp[i].pos,tmp[i].value,0,N-1,1);
        for(int i=0;i<N;i++)
            printf("%d%c",ans[i],i==N-1?'\n':' '); 
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值