poj1724 广搜之找路

/*
ROADS
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10989 Accepted: 4048
Description


N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 


We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 
Input


The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 


The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 


Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
S is the source city, 1 <= S <= N 
D is the destination city, 1 <= D <= N 
L is the road length, 1 <= L <= 100 
T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.
Output


The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 
Sample Input


5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output


11
Source*/
/
//思路就是广搜
//中间处理技巧一个是vector<vector<Road>> cityMap的表达形式,将每个城市作为元素储存近vector,
//同时每个城市也是一个vector,里面储存了每条通向这个城市的道路
//此外的技巧是剪枝,一个是当totalLen>minLen时就继续循环,不在往下进行,一个是用int[d][cost]这个数组,储存没个城市花费一定
//时的最短路径,当花费相同时如果路径比这个大的话就忽略。此外在DFS中,先将visit置1,在置0,因为置1之后表示走过d这个城市了
//经dfs后,在去除,因为之前的循环可能以后还要经过d这个城市,totalLen和totalcost也都要变回之前的,递归的出口就是s==n,此时在吧
//minlen和totallen比较,取小的
/
#include<iostream>
#include<vector>
#include<string.h>


using namespace std;


struct Road{
int d,t,l;
};
vector< vector<Road> >cityMap(110);
int K,N,R;


int totalCost;
int totalLen;
int minLen;
bool visit[110];
int minL[110][10100];


void DFS(int );
int main(){
cin >> K >> N >> R;
for(int i = 0;i < R; ++i)
{
int s;
Road r;
cin >> s >> r.d >> r.l >> r.t;
cityMap[s].push_back(r);
}
for(int i = 0 ;i < 110;i++)
{
for(int j =  0; j  < 10100;j++)
{
minL[i][j] = 1 << 30;
}
}
memset(visit,0,sizeof(visit));
totalCost = 0;
totalLen = 0;
minLen = 1 << 30;
visit[1] = 1;
DFS(1);
if(minLen < (1 << 30))
cout << minLen << endl;
else
cout << -1 << endl;
}
void DFS(int s)
{
if(s == N)
{
minLen = min(minLen,totalLen);
return;
}
for(int i = 0;i < cityMap[s].size(); ++i)
{
int d = cityMap[s][i].d;
if(!visit[d])
{
int cost = cityMap[s][i].t + totalCost;
if( cost > K)
continue;
if(totalLen + cityMap[s][i].l >= minLen || totalLen + cityMap[s][i].l >= minL[d][cost])
continue;
totalCost += cityMap[s][i].t;
totalLen += cityMap[s][i].l;
minL[d][cost] = totalLen;
visit[d] = 1;
DFS(d);
visit[d] = 0;
totalCost -= cityMap[s][i].t;
totalLen -= cityMap[s][i].l;
}
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值