A Knight's Journey(深搜)

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

题意:给你一个n*m大小的矩形,该旗子走“日”字,问能否走完整个棋盘!

思路:果断搜!可惜卡在输出处!!!!!!!!!

#include<stdio.h>
#include<iostream>
#include<string.h>

using namespace std;

int a,b,f;
int flag[30][30];
int ax[30],ay[30];
int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};

void dfs(int x,int y,int step)
{
    int bx,by,i;
    ax[step]=x;
    ay[step]=y;
    if(step==a*b)
    {
        f=1;return ;
    }
    for(i=0;i<8;i++)
    {
        bx=dir[i][0]+x;
        by=dir[i][1]+y;
        if(bx>=1&&bx<=b&&by>=1&&by<=a&&!flag[bx][by]&&!f)
        {
            flag[bx][by]=1;
            dfs(bx,by,step+1);
            flag[bx][by]=0;
        }
    }
}

int main()
{
    int n,fu=0,k;
    cin>>n;
    for(k=1;k<=n;k++)
    {
        fu++;
        f=0;
        cin>>a>>b;
        memset(flag,0,sizeof(flag));
        printf("Scenario #%d:\n",fu);
        flag[1][1]=1;
        dfs(1,1,1);
        if(!f)
        printf("impossible");
        else
        {
            for(int i=1;i<=a*b;i++)
            printf("%c%d",ax[i]+'A'-1,ay[i]);
        }
        printf(k==n?"\n":"\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值