Triangular Sums

题目:122

Triangular Sums

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145
c++版:
<span style="font-family:SimSun;font-size:18px;">#include<iostream>
//#include<cstdlib>
using namespace std;

int main(){
    int test,i,m,sum,t = 1;
    cin>>test;
    while(test--){
    sum = 0;
    cin>>m; 
    for(i=1;i<=m;i++)
    sum += i*(i+1)*(i+2)/2;
    cout<<t++<<" "<<m<<" "<<sum<<endl;
    }
   // system("pause");
    return 0;
}</span>
<span style="font-family:SimSun;font-size:18px;"></span> 
<span style="font-family:SimSun;font-size:18px;">//W(n)=1*T(2)+2*T(3)+...+n*T(n+1)
//T(n)=n*(n+1)/2=1+2+3...+n</span>
<span style="font-family:SimSun;font-size:18px;"></span> 
c语言版:
#include<stdlib.h>
#include<stdio.h>
int main()
{
int n,m,i,j=1;
scanf("%d",&n);
while(n--)
{
int x,sum=0;
scanf("%d",&x);
for(i=1; i<=x; i++)
sum+=i*(i+1)*(i+2)/2; 
printf("%d %d %d\n",j++,a,sum); 
} 
system("pause");
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值