Number Sequence【矩阵快速幂】

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 192483    Accepted Submission(s): 48142


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
 
1 1 3 1 2 10 0 0 0
 

Sample Output
 
 
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining
 

思路:

矩阵快速幂。

矩阵转移方程:

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stack>
#include<stdlib.h>
#include<ctype.h>
using namespace std;
#define LL long long
#define mod 7
struct node
{
    int s[2][2];
};
node multi(node a,node b)
{
    node c={0};
    for(int i=0;i<2;i++)
    for(int j=0;j<2;j++)
    for(int k=0;k<2;k++)
    c.s[i][j]=(c.s[i][j]+a.s[i][k]*b.s[k][j])%mod;
    return c;
}
node quick_pow(node a,int p)
{
    node res={0};
    for(int i=0;i<2;i++)
        res.s[i][i]=1;
    while(p)
    {
        if(p&1) res = multi(res,a);
        p>>=1;
        a = multi(a,a);
    }
    return res;
}
int main()
{
    int a,b,n;
    while(scanf("%d%d%d",&a,&b,&n) && a+b+n)
    {
        node A;
        A.s[0][0]=a;
        A.s[0][1]=b;
        A.s[1][0]=1;
        A.s[1][1]=0;
        node B = {0};
        B.s[0][0]=1;
        B.s[1][0]=1;
        printf("%d\n",multi(quick_pow(A,n-1),B).s[1][0]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值