HDU 1098 Ignatius's puzzle


Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5765    Accepted Submission(s): 3968


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43

数论题,整整一节课都是它的了,还参看了很多orz的博客,不过也还是学到了点东西.生气

考虑特殊值,当X=1时,就可以得到那什么东西:

当x=1时f(x)=18+ka;有因为f(x)能被65整出,这可得出f(x)=n*65;

即:假设存在这个数a ,因为对于任意x方程都成立,所以,18+ka=n*65;若该方程有整数解则说明假设成立。

对于方程有整数解:a*x+b*y=m;如a,b的最大公约数为1,则有整数解

ax+by = c的方程有解的一个充要条件是:c%gcd(a, b) == 0


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int gcd(int a, int b)
{
    return b? gcd(b, a%b):a;
}
int main()
{
    int m;
    while(~scanf("%d", &m))
    {
        if(gcd(65, m)==1)
        {
            for(int i = 1;; i++)
            {
                if((i*65-18)%m == 0)
                {
                    printf("%d\n", (i*65-18)/m);
                    break;
                }
            }
        }
        else printf("no\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值