poj 1463 Strategic game(最小点覆盖树形DP)

题目链接:http://poj.org/problem?id=1463

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source


题意很简单,就是用最少的点覆盖所有点...

每个点有两种状态

1.dp[u][0]表示u属于点覆盖,且与u为根的所有子树所连接的边都被覆盖的情况下最小点

2.dp[u][1]表示u不属于点覆盖,且与u为根的所有子树所连接的边都被覆盖的情况下最小点

dp[u][0]等于每个儿子节点的两种状态的最小值加1

dp[u][0]+=min(dp[v][0],dp[v][1]);

第二种状态dp[u][1]要求所有与u链接的边都被覆盖,但是u不属于覆盖点,那么u的所有子节点必须属于点覆盖,即u的第二种状态只与所有子节点的第一种状态有关

dp[u][1]+=dp[to][0]

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1505*2;
struct node
{
    int to,next;
}e[maxn];
int head[maxn],vis[maxn];
int dp[maxn][3];
int n,cnt;
void add(int x,int y)
{
    e[cnt].to=y;
    e[cnt].next=head[x];
    head[x]=cnt++;
}
void dfs(int u)
{
    dp[u][0]=1;
    dp[u][1]=0;
    vis[u]=1;
    for(int k=head[u];k!=-1;k=e[k].next)
    {
        int to=e[k].to;
        if(!vis[to])
        {
            dfs(to);
            dp[u][0]+=min(dp[to][0],dp[to][1]);
            dp[u][1]+=dp[to][0];
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)==1)
    {
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        cnt=0;
        char s1[5],s2[5],s3[5];
        int a,b,c;
        for(int i=0;i<n;i++)
        {
            scanf("%d%1s%1s%d%1s",&a,s1,s2,&b,s3);
            while(b--)
            {
                scanf("%d",&c);
                add(a,c);
                add(c,a);
            }
        }
        dfs(0);
        printf("%d\n",min(dp[0][0],dp[0][1]));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值