Poj 2981:大整数加法

题目描述:

求两个不超过200位的非负整数的和。

样例输入:

22222222222222222222
33333333333333333333

样例输出:

55555555555555555555

解题思路:

本题思路比较明显,对于输入的两个数,从个位开始一次相加。注意0+0的情况

代码:

#include<iostream>
#include<string.h>

using namespace std;

char a[200];
char b[200];

void input() {
    cin >> a >> b;
}

void add() {
    int lenA = strlen(a);
    int lenB = strlen(b);
    char sum[201];
    int t,cnt;
    if(lenA >= lenB) {
        t = 0;
        cnt = 0;
        for(int i = lenA - 1, j = lenB -1; i >= 0 ; i -- , j--){
            int s;
            if(j < 0) {
                s = (a[i] -'0' + 0) + cnt;
            }else {
                s = (a[i] -'0' + 0) + (b[j] - '0' + 0) + cnt;
            }
            sum[t ++] = (s % 10) + '0';
            if(s >= 10) {
                cnt = s / 10;
            }else {
                cnt = 0;
            }
        }

    }else {
        t = 0;
        cnt = 0;
        for(int i = lenB - 1, j = lenA-1; i >= 0 ; i -- , j--){
            int s;
            if(j < 0) {
                s = (b[i] -'0' + 0) + cnt;
            }else {
                s = (b[i] -'0' + 0) + (a[j] - '0' +0) + cnt;
            }
            sum[t ++] = (s % 10) + '0';
            if(s >= 10) {
                cnt = s / 10;
            }else {
                cnt = 0;
            }
        }
    }
    if(cnt > 0) {
            sum[t++] = cnt + '0';
    }


    while(t --) {
        if(sum[t] != '0') {
            break;
        }
    }
    t ++;
    if(t == 0) {
        cout << "0" << endl;
    }
    while(t -- ) {
        cout << sum[t];
    }

  //  cout << endl;
}
int main() {
    input();
    add();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值