POJ 2677(双调旅行商问题<bictonicTSP>

                                                                                                   Tour
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3470Accepted: 1545

Description

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi,yi >. John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x-coordinates. 
Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result. An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input

3
1 1
2 3
3 1
4
1 1
2 3
3 1
4 2

Sample Output

6.47
7.89


#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
#define INF 0x3f3f3f3f
const int maxn=10001;
using namespace std;

double dp[maxn][maxn],dis[maxn][maxn];
int n;

struct Point{
    int x;
    int y;
}p[maxn];

bool cmp(Point a,Point b)
{
    return a.x<b.x;
}

double cal(Point a,Point b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(double)(a.y-b.y)*(a.y-b.y));
}


double bitonicTSP()
{
    int i,j;
    dp[0][0]=0;
    dp[1][0]=dis[0][1];        //initial  dis[0][1]不是dis[1][0]

    for(i=1;i<n-1;i++)
    {
        dp[i+1][i]=INF;
        for(j=0;j<i;j++)
        {
            dp[i+1][j]=dp[i][j]+dis[i][i+1];
            dp[i+1][i]=min(dp[i+1][i],dp[i][j]+dis[j][i+1]);

        }
    }

    return dp[n-1][n-2]+dis[n-2][n-1];
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%d%d",&p[0].x,&p[0].y);
        if(n==1) {printf("0.00\n");continue;}

        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
        }

        sort(p,p+n,cmp);
        for(int i=0;i<n-1;i++)
            for(int j=i+1;j<n;j++)
            {
                dis[i][j]=cal(p[i],p[j]);          //注意这里,我的代码,要求dis[i][j],i<j,
            }

        printf("%.2lf\n",bitonicTSP());

    }
    return 0;

}

(表示确实很难理解!大哭

具体思想,欢迎大家看:http://blog.csdn.net/code_or_code/article/details/26283159



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值