【博弈】hdoj2147 kiki's game

kiki's game

 

Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

 


 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

 


 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

 


 

Sample Input

 

5 3 5 4 6 6 0 0

 


 

Sample Output

 

What a pity! Wonderful! Wonderful!

 

分析:

N:必胜点(如果左边,左下角,下角有一个P点,那么这个点就是N点)

P:必败点(如果左边,左下角,下角全都是N点,那么这个点就是P点)

  (1) 所有终结点是必败点(P点);

  (2) 从任何必胜点(N点)操作,至少有一种方法可以进入必败点(P点);

  (3)无论如何操作,从必败点(P点)都只能进入必胜点(N点).

最后棋子一定到达(n,m)这个点,所以我们从这个点是必败点,从这里开始画出NP图

找到规律得,行数和列数只要有一个偶数,就能赢。

代码如下:

#include<stdio.h>
int main()
{int n,m;
while(scanf("%d%d",&n,&m),n+m)
    {if(n%2==0||m%2==0) printf("Wonderful!\n");
    else printf("What a pity!\n");
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值