poj 2406 kmp next数组应用

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 38122 Accepted: 15791

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4

3

#include <iostream>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <ctime>
using namespace std;

#pragma comment(linker,"/STACK:102400000,102400000") /// kuo zhan
#define clr(s,x) memset(s,x,sizeof(s))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define lowbit(x) (x&(-x))
#define PB push_back
#define For(i,a,b) for(int i=a;i<b;i++)
#define FOR(i,a,b) for(int i=a;i<=b;i++)

typedef long long               LL;
typedef unsigned int            uint;
typedef unsigned long long      ULL;
typedef vector<int>             vint;
typedef vector<string>          vstring;

void RI (int& x){
    x = 0;
    char c = getchar ();
    while (c == ' '||c == '\n')    c = getchar ();
    bool flag = 1;
    if (c == '-'){
        flag = 0;
        c = getchar ();
    }
    while (c >= '0' && c <= '9'){
        x = x * 10 + c - '0';
        c = getchar ();
    }
    if (!flag)    x = -x;
}
void RII (int& x, int& y){RI (x), RI (y);}
void RIII (int& x, int& y, int& z){RI (x), RI (y), RI (z);}


const double PI  = acos(-1.0);
const int maxn   = 1e6 + 100;
const int maxm   = 1e6 + 100;
const LL mod     = 1e9 + 7;
const double eps = 1e-9;
const int INF    = 0x7fffffff;

/************************************END DEFINE*********************************************/
char s[maxn],t[maxm];
int nxt[maxm];
int n;
void get_next(){
    clr(nxt,0);
    int len = strlen(t);
    nxt[0] = 0;
    nxt[1] = 0;
    For(i,1,len){
        int j = nxt[i];
        while(j && t[i] != t[j])j = nxt[j];
        nxt[i+1] = t[i] == t[j] ? j+1 : 0;
    }
}

int kmp(){
    get_next();
    int lens = strlen(s), lent = strlen(t);
    int j = 0,cnt = 0;
    For(i,0,lens){
        while(j && t[j] != s[i])j = nxt[j];
        if(t[j] == s[i]) j++;
        if(j == lent){
            cnt ++;
            j = nxt[j];
        }
    }
    return cnt;
}

int main()
{
    while(~scanf("%s",t)){
        if(t[0]=='.')break;
        get_next();
        if(strlen(t)%(strlen(t)-nxt[strlen(t)])==0)
            printf("%d\n",strlen(t)/(strlen(t)-nxt[strlen(t)]));
        else printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值