KMP(3)--poj2406(next数组的应用)

  Power Strings

                                                    Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.


        这道题就是求字符串的周期,即问一个字符串写成(a)^n的形式,求最大的n. 
      因为字符串可以写成(a)^n的形式,根据KMP的next函数的性质,已知字符串t第K个字符的next[k],那么d=k-next[k],如果k%d==0,那么t[1……k]最多可均匀的分成k/d份。也就是可以生成一个长度为d的重复度为k/d的字串。接下来就简单了,上代码:
       
#include<stdio.h>
#include<string.h>
#define MAX 1000010
char str[MAX];
int next[MAX];
void GetNextval(){
	int i=0;
	int j=-1;
	next[0]=-1;
	int len=strlen(str);
	while(i<len){
		if(j==-1||str[i]==str[j]){
			next[++i]=++j;
		}
		else j=next[j];
	}
}
int main()
{
	int i;
	while(scanf("%s",str)!=EOF){
		if(str[0]=='.')break;
		GetNextval();        
		int max=1;
		int len=strlen(str);                 //利用求得的next[len],按我说的性质就可求得周期
			if(len%(len-next[len])==0)
				max=len/(len-next[len]);
		printf("%d\n",max);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值