Buy Tickets(线段树)

Buy Tickets
Time Limit: 4000MS  Memory Limit: 65536K
Total Submissions: 10862  Accepted: 5273

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

       题意:

       N(1到200000)个人插队问题。给出N个人的插队位置(0到N-1)和编号(0到32767),最终输出这N个人的顺序。

      

       思路:

       人一个个的插入队列中,如果按顺序的插入的话,这个人当前的位置不一定是最终的位置,可能会被后面的人插队而导致退后,所以应该换种思考方式思考。从最后一个开始往前插空,最后一个插进去的位置一定是固定的,所以应该从最后一个开始往前固定每个人的座位,前面pos的值代表该人前面有多少个空位,用线段树维护每个区间的空位数即可求出最终序列。

 

       AC:

#include<stdio.h>
#define MAX (200000+5)  //这里要括号
typedef struct
{
	__int64 l,r,ex;
}node;

node no[MAX*3];
__int64 ex[MAX],num[MAX],fin[MAX];
__int64 t;  //定义t全局变量

void build(__int64 from,__int64 to,__int64 i)
{
	__int64 mid=(from+to)/2;
	no[i].l=from;
	no[i].r=to;
	if(from==to)
	{
		no[i].ex=1;
		return;
	}
	build(from,mid,2*i);
	build(mid+1,to,2*i+1);
	no[i].ex=no[2*i].ex+no[2*i+1].ex;
}

void find(__int64 p,__int64 i)
{
	if(no[i].l==no[i].r)
	{
		no[i].ex--;
//插到这个位置之后,这个位置清零
		fin[no[i].l]=num[t];
//用fin数组保存最终的顺序
		return;
	}
	if(no[2*i].ex<=p) find(p-no[2*i].ex,2*i+1);
//如果左儿子的空位数小于这个位置所需要的空位数,则访问右儿子
//要减去左儿子的空位数再访问
	else              find(p,2*i);
	no[i].ex=no[2*i].ex+no[2*i+1].ex;
}

int main()
{
	__int64 n;
	while(scanf("%I64d",&n)!=EOF)
	{
		for(__int64 i=1;i<=n;i++)
			scanf("%I64d%I64d",&ex[i],&num[i]);
		build(1,n,1);
//从最后一个开始往前插入空位
		for(t=n;t>=1;t--)
			find(ex[t],1);
		for(__int64 i=1;i<=n;i++)
			{
				printf("%d",fin[i]);
				i==n?printf("\n"):printf(" ");
			}
	}
	return 0;
}

 

        总结:

        1.同样也是多输入,细心;

        2.灵活运用,多加练习。

 

14 - 7 - 23  AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 200005;

int q[MAX * 10], num[MAX];
int a[MAX], b[MAX];

void push_up (int node) {
        q[node] = q[node << 1] + q[node << 1 | 1];
}

void build(int node, int l, int r) {
        if (l == r) {
                q[node] = 1;
        } else {
                int mid = (r + l) >> 1;
                build (node << 1, l, mid);
                build (node << 1 | 1, mid + 1, r);
                push_up(node);
        }
}

void update (int node, int l, int r, int k, int who) {
        if (l == r) {
                q[node] = 0;
                num[l] = who;
                return;
        }

        int mid = (r + l) >> 1;
        if (q[node << 1] > k) update(node << 1, l, mid, k, who);
        else update(node << 1 | 1, mid + 1, r, k - q[node << 1], who);

        push_up(node);
}

int main() {
        int n;

        while (~scanf("%d", &n)) {
                build (1, 1, n);

                for (int i = 1; i <= n; ++i) {
                        scanf("%d%d", &a[i], &b[i]);
                }

                for (int i = n; i >= 1; --i) {
                        update(1, 1, n, a[i], b[i]);
                }

                printf("%d", num[1]);
                for (int i = 2; i <= n; ++i) {
                        printf(" %d", num[i]);
                }
                printf("\n");
        }

        return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值