Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output
For each case, print the number of prime numbers you have found out.
Sample Input
3
2 3 4
Sample Output
板子:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
inline int read(){
int x=0,f=0;char ch=getchar();
while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
return f?-x:x;
}
const int S=5;
ll qmul(ll a,ll b,ll c){
ll ans=0;
a%=c,b%=c;
while(b){
if(b&1){
ans+=a;
if(ans>c)ans-=c;
}
a<<=1;;
if(a>c)a-=c;
b>>=1;
}
return ans;
}
ll qpow(ll a,ll b,ll c){
ll ans=1;
a%=c;
while(b){
if(b&1)ans=qmul(ans,a,c);
a=qmul(a,a,c);
b>>=1;
}
return ans;
}
bool check(ll a,ll n,ll x,ll t){
ll ans=qpow(a,x,n);
ll last=ans;
for(int i=1;i<=t;++i){
ans=qmul(ans,ans,n);
if(ans==1&&last!=i&&last!=n-1)return true;
last=ans;
}
return ans!=1;
}
bool Miller_Rabin(ll n){
if(n<2)return false;
if(n==2||n==3||n==5||n==7)return true;
if((n&1)==0)return false;
ll x=n-1,t=0;
srand(time(NULL));
for(int i=0;i<S;++i){
ll a=rand()%(n-1)+1;
if(check(a,n,x,t))return false;
}
return true;
}
int main(){
int t,cnt;
while(~scanf("%d",&t)){
cnt=0;
while(t--)cnt+=Miller_Rabin(read());
printf("%d\n",cnt);
}
return 0;
}