堆的应用:Sequence

Sequence Time Limit:6000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4


#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
#include <iostream>

using namespace std;

int main(){
    int n, m;
    int cnt , i, j, k;
    int str1[2010], str2[2010];
    priority_queue<int> str;
    cin >> cnt;
    while(cnt--){
        cin >> m >> n;
        memset(str1, 0, sizeof(str1));
        memset(str2, 0, sizeof(str2));
        for(i = 0; i < n; i ++)
            scanf("%d", &str1[i]);
        sort(str1, str1 + n);
        for(i = 1; i < m; i++){
            for(j = 0; j < n; j++)
                scanf("%d", &str2[j]);
            sort(str2, str2 + n);
            for(j = 0; j < n; j ++)
                str.push(str2[0] + str1[j]);
            for(j = 1; j < n; j ++){
                for(k = 0; k < n; k ++){
                    if(str2[j] + str1[k] > str.top())
                        break;
                    str.pop();             //只要新的比堆里最大的小,就把堆里最大的扔掉,把新的放进堆
                    str.push(str2[j] + str1[k]);
                }
            }
            for(j = 0; j < n; j ++){
                str1[n - j -1] = str.top(); //更新str1
                str.pop();//最后堆为空
            }
        }
        for(i = 0; i < n; i ++)
            {
                if(i != 0)
                    cout<<" ";
                cout<<str1[i];
            }
  cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值