POJ 2155——Matrix(树套树,二维树状数组,二维线段树)

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18460 Accepted: 6950

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1


————————————————————————分割线——————————————————


题目大意:

有一个n*n的矩形平面,里面每个点初始为0,有两种操作:

1.将左上角为(x1,y1),右下角为(x2,y2)的矩形区域中的每个点,把0变成1,把1变成0

2.查询点(x,y)当前的值


思路:

对于翻转矩形区域,一种是向上,一种向下,跟一维是类似的,辅助数组c[][]来记录修改次数


二维树状数组:

向上修改,向下统计:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m;
int c[1010][1010];
void update(int x,int y)
{
    for(int i=x;i<=n;i+=i&-i){
        for(int j=y;j<=n;j+=j&-j){
            c[i][j]++;
        }
    }
}
int getsum(int x,int y)
{
    int sum=0;
    for(int i=x;i>0;i-=i&-i){
        for(int j=y;j>0;j-=j&-j){
            sum+=c[i][j];
        }
    }
    return sum;
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        memset(c,0,sizeof(c));
        scanf("%d %d",&n,&m);
        getchar();
        while(m--){
            char ch;
            ch=getchar();
            if(ch=='C'){
                int x1,y1,x2,y2;
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                getchar();
                update(x1,y1);
                update(x2+1,y2+1);
                update(x2+1,y1);
                update(x1,y2+1);
            }
            if(ch=='Q'){
                int x,y;
                scanf("%d %d",&x,&y);
                getchar();
                printf("%d\n",getsum(x,y)&1);
            }
        }
        if(T) printf("\n");
    }
    return 0;
}


向下修改,向上统计:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m;
int c[1010][1010];
void update(int x,int y)
{
    for(int i=x;i>0;i-=i&-i){
        for(int j=y;j>0;j-=j&-j){
            c[i][j]++;
        }
    }
}
int getsum(int x,int y)
{
    int sum=0;
    for(int i=x;i<=n;i+=i&-i){
        for(int j=y;j<=n;j+=j&-j){
            sum+=c[i][j];
        }
    }
    return sum;
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        memset(c,0,sizeof(c));
        scanf("%d %d",&n,&m);
        getchar();
        while(m--){
            char ch;
            ch=getchar();
            if(ch=='C'){
                int x1,y1,x2,y2;
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                getchar();
                update(x2,y2);
                update(x1-1,y2);
                update(x2,y1-1);
                update(x1-1,y1-1);
            }
            if(ch=='Q'){
                int x,y;
                scanf("%d %d",&x,&y);
                getchar();
                printf("%d\n",getsum(x,y)&1);
            }
        }
        if(T) printf("\n");
    }
    return 0;
}


二维线段树:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define rep(i,n) for(int i=0;i<n;++i)
#define mes(s,c) memset(s,c,sizeof(s))
const int maxn=1001;
using namespace std;
int sum[maxn<<2][maxn<<2];
int n,m;
int ans;
void Subbuild(int st,int l,int r,int rt)
{
    sum[st][rt]=0;
    if(l==r) return ;
    int m=(l+r)>>1;
    Subbuild(st,lson);
    Subbuild(st,rson);
}
void Build(int l,int r,int rt)
{
    Subbuild(rt,1,n,1);
    if(l==r) return;
    int m=(l+r)>>1;
    Build(lson);
    Build(rson);
}
void Subupdate(int L,int R,int st,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        sum[st][rt]^=1;
        return ;
    }
    int m=(l+r)>>1;
    if(L<=m) Subupdate(L,R,st,lson);
    if(m<R) Subupdate(L,R,st,rson);
}
void Update(int x1,int y1,int x2,int y2,int l,int r,int rt)
{
    if(x1<=l&&r<=x2){
        Subupdate(y1,y2,rt,1,n,1);
        return ;
    }
    int m=(l+r)>>1;
    if(x1<=m) Update(x1,y1,x2,y2,lson);
    if(m<x2) Update(x1,y1,x2,y2,rson);
}
void Subquery(int L,int R,int st,int l,int r,int rt)
{
    ans^=sum[st][rt];
    if(l==r) return;
    int m=(l+r)>>1;
    if(R<=m) Subquery(L,R,st,lson);
    else Subquery(L,R,st,rson);
}
void Query(int L,int R,int l,int r,int rt)
{
    Subquery(L,R,rt,1,n,1);
    if(l==r) return ;
    int m=(l+r)>>1;
    if(L<=m) Query(L,R,lson);
    else Query(L,R,rson);
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        scanf("%d%d",&n,&m);
        Build(1,n,1);
        char op[10];
        int x1,y1,x2,y2,x,y;
        while(m--){
            scanf("%s",op);
            if(op[0]=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                Update(x1,y1,x2,y2,1,n,1);
            }else{
                ans=0;
                scanf("%d%d",&x,&y);
                Query(x,y,1,n,1);
                printf("%d\n",ans);
            }
        }
        if(T) puts(" ");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值