POJ 3667——Hotel(线段树,区间合并)

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12065 Accepted: 5237

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and D(b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

——————————————————————分割线——————————————————


题目大意:

给定一段长为n的区间,初始的时候为空,然后有两种操作

1:查询是否存在长度为x的连续区间,若存在,则返回最左边的端点,否则输出0

2:将区间(l,l+x-1)清空


思路:

线段树的区间合并问题:

要查询连续区间长度,所以要记录最长的连续区间,一段区间的连续可以分为左连续,右连续,中间连续,然后记录就可以了

父节点左连续区间为左儿子左连续,如果左儿子在整个左区间内连续则再加上右儿子左连续

父节点右连续区间为右儿子右连续,如果右儿子在整个右区间内连续则再加上左儿子右连续

父节点中间连续区间为左儿子右连续加上右儿子左连续

然后记录每个节点总的最长连续区间的值


每次向上更新或者向下延迟都要重新计算节点信息

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=50001;
using namespace std;
int n,m;
int cover[maxn<<2],lc[maxn<<2],rc[maxn<<2],mc[maxn<<2];
void push_down(int rt,int m)
{
    if(cover[rt]!=-1){
        cover[rt<<1]=cover[rt<<1|1]=cover[rt];
        mc[rt<<1]=lc[rt<<1]=rc[rt<<1]=cover[rt] ? 0:(m-(m>>1));
        mc[rt<<1|1]=lc[rt<<1|1]=rc[rt<<1|1]=cover[rt] ? 0:(m>>1);
        cover[rt]=-1;
    }
}
void push_up(int rt,int m)
{
    lc[rt]=lc[rt<<1];
    rc[rt]=rc[rt<<1|1];
    if(lc[rt]==(m-(m>>1))) lc[rt]+=lc[rt<<1|1];
    if(rc[rt]==(m>>1)) rc[rt]+=rc[rt<<1];
    mc[rt]=max(rc[rt<<1]+lc[rt<<1|1],max(mc[rt<<1],mc[rt<<1|1]));
}
void build(int l,int r,int rt)
{
    cover[rt]=-1;
    mc[rt]=lc[rt]=rc[rt]=r-l+1;
    if(l==r) return ;
    int m=(r+l)>>1;
    build(lson);
    build(rson);
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        cover[rt]=c;
        mc[rt]=lc[rt]=rc[rt]=c ? 0:(r-l+1);
        return ;
    }
    push_down(rt,r-l+1);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(m<R) update(L,R,c,rson);
    push_up(rt,r-l+1);
}
int query(int x,int l,int r,int rt)
{
    if(l==r) return l;
    push_down(rt,r-l+1);
    int m=(l+r)>>1;
    if(mc[rt<<1]>=x) return query(x,lson);
    else if(rc[rt<<1]+lc[rt<<1|1]>=x) return m-rc[rt<<1]+1;
    else return query(x,rson);
}
int main()
{
    scanf("%d %d",&n,&m);
    build(1,n,1);
    int op,x,l,r;
    while(m--) {
        scanf("%d",&op);
        if(op==1){
            scanf("%d",&x);
            if(mc[1]<x){
                printf("0\n");continue;
            }
            int index=query(x,1,n,1);
            update(index,index+x-1,1,1,n,1);
            printf("%d\n",index);
        }
        else{
            scanf("%d %d",&l,&r);
            update(l,l+r-1,0,1,n,1);
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值