POJ2488 骑士的旅行

大体意思是一个骑士,在p*q棋盘上以一个方向走两格,再垂直走一格的方式走遍每一个格子。
这题需要用到深搜和回溯,还有一点就是字典序排列,所以每次都要从(A,1)开始搜索。
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:A1Scenario #2:impossibleScenario #3:A1B3C1A2B4C2A3B1C3A4B2C4

 

 

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int t,n,m;
int s[26][26];//标记数组
char p[60];
static int dis[8][2]={-2, -1, -2, 1, -1, -2, -1, 2, 1, -2, 1, 2, 2, -1, 2, 1};//方向
int dfs(int x,int y,int mark)
{
    if(mark==n*m)  return 1;
    int x1,y1;
    for(int i=0;i<8;++i)
    {
        x1=x+dis[i][0];
        y1=y+dis[i][1];
        if(x1>=0&&x1<m&&y1>=0&&y1<n&&s[y1][x1]==0)
        {
            s[y1][x1]=1;
            p[(mark<<1)]=x1+'A';//记录列
            p[(mark<<1)+1]=y1+'1';//记录行
            if(dfs(x1,y1,mark+1))
                 return 1;
            s[y1][x1]=0;
        }
    }
    return 0;
}

int main()
{

    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        scanf("%d %d",&n,&m);
        memset(s,0,sizeof(s));
        memset(p,0,sizeof(p));
        s[0][0]=1;
        p[0]='A';
        p[1]='1';
        if(dfs(0,0,1))
        {
            printf("Scenario #%d:\n",i);
            for(int j=0;j<strlen(p);j++)
                printf("%c",p[j]);
            printf("\n\n");
        }
        else
        {
             printf("Scenario #%d:\nimpossible\n\n",i);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值