POJ-3259

65 篇文章 0 订阅

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 39402 Accepted: 14473

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source
USACO 2006 December Gold

裸SPFA

#include <cstdio>
#include <cstring>
#include <iostream>
#define Inf 0x7fffffff
using namespace std;
int tot,x,y,t,n,m,w,f,z[800000],a[501],val[501],F[501];
bool jud[501];
struct thing
{
    int n,pre,v;
} b[800000];
void insert(int x,int y,int t)
{
    tot++;
    b[tot].n=y;
    b[tot].pre=a[x];
    b[tot].v=t;
    a[x]=tot;
}
int main()
{
    cin>>f;
    for(int T=1;T <= f;T++)
    {
        memset(F,0,sizeof(F));
        memset(jud,0,sizeof(jud));
        memset(a,0,sizeof(a));
        tot=0;
        cin>>n>>m>>w;
        for(int i=1;i <= n;i++)
            val[i]=Inf;
        for(int i=1;i <= m;i++)
        {
            cin>>x>>y>>t;
            insert(x,y,t);
            insert(y,x,t);
        }
        for(int i=1;i <= w;i++)
        {
            cin>>x>>y>>t;
            insert(x,y,-t);
        }
        for(int i=1;i <= n;i++)
        {
            insert(0,i,0);
        }
        int s=1,t=2;
        z[s]=0;
        jud[0]=true;
        val[0]=0;
        while(s != t)
        {
            int j=a[z[s]];
            while (j)
            {
                if(val[b[j].n] > val[z[s]]+b[j].v)
                {
                    val[b[j].n]=val[z[s]]+b[j].v;
                    if(!jud[b[j].n])
                    {
                        jud[b[j].n]=true;
                        z[t]=b[j].n;
                        F[b[j].n]++;
                        if (F[b[j].n] >= n) break;
                        t++;
                    }
                }
                j=b[j].pre;
            }
            if (F[b[j].n] >= n)
            {
                val[0]=-1;
                break;
            }
            jud[z[s]]=false;
            s++;
        }
        if(val[0] < 0)
        {
            cout<<"YES"<<endl;
        }
        else cout<<"NO"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值