POJ-1691 Painting A Board

34 篇文章 0 订阅
7 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3616 Accepted: 1798

Description

The CE digital company has built an Automatic Painting Machine (APM) to paint a flat board fully covered by adjacent non-overlapping rectangles of different sizes each with a predefined color. 

To color the board, the APM has access to a set of brushes. Each brush has a distinct color C. The APM picks one brush with color C and paints all possible rectangles having predefined color C with the following restrictions: 
To avoid leaking the paints and mixing colors, a rectangle can only be painted if all rectangles immediately above it have already been painted. For example rectangle labeled F in Figure 1 is painted only after rectangles C and D are painted. Note that each rectangle must be painted at once, i.e. partial painting of one rectangle is not allowed. 
You are to write a program for APM to paint a given board so that the number of brush pick-ups is minimum. Notice that if one brush is picked up more than once, all pick-ups are counted. 

Input

The first line of the input file contains an integer M which is the number of test cases to solve (1 <= M <= 10). For each test case, the first line contains an integer N, the number of rectangles, followed by N lines describing the rectangles. Each rectangle R is specified by 5 integers in one line: the y and x coordinates of the upper left corner of R, the y and x coordinates of the lower right corner of R, followed by the color-code of R. 
Note that: 
  1. Color-code is an integer in the range of 1 .. 20. 
  2. Upper left corner of the board coordinates is always (0,0). 
  3. Coordinates are in the range of 0 .. 99. 
  4. N is in the range of 1..15.

Output

One line for each test case showing the minimum number of brush pick-ups.

Sample Input

1
7
0 0 2 2 1
0 2 1 6 2
2 0 4 2 1
1 2 4 4 2
1 4 3 6 1
4 0 6 4 1
3 4 6 6 2

Sample Output

3

Source

Tehran 1999

#include <cstdio>
#include <cstring>
#include <iostream>
#define MAXN 2147483647
using namespace std;
int f[16][16],d[16],x1[16],x2[16],y1[16],y2[16],col[16],ans,n,m;
bool done[16];
bool jud(int i,int j)
{
	if(x1[i] <= x1[j] && x1[j] <= x2[i]) return true;
	if(x1[i] <= x2[j] && x2[j] <= x2[j]) return true;
	return false;
}
void dfs(int k,int tot,int d[16],bool done[16])
{
	int Tot,D[16];
	bool DONE[16];
	if(k >= ans) return;
	if(tot == n) 
	{
		ans=k;
		return;
	}
	for(int i = 1;i <= 20;i++)
	{
		for(int j = 1;j <= n;j++)
	  	 if(!done[j] && d[j] == 0 && col[j] == i)
	  	 {
	  	 	 bool flag;
	  	 	 Tot=tot;
	  	 	 for(int I = 1;I <= n;I++) D[I]=d[I];
	  	 	 for(int I = 1;I <= n;I++) DONE[I]=done[I];
	  	  	 do
	  	  	 {
	  	  	 	flag=false;
	  	  	 	for(int now = 1;now <= n;now++)
	  	  	 	 if(!DONE[now] && D[now] == 0 && col[now] == i) 
				 {
				 	DONE[now]=true;
				 	Tot++;
				 	for(int l = 1;l <= n;l++)
				 	 if(f[now][l]) D[l]--;
				 	flag=true;
				 } 
			 } while(!flag);
			 dfs(k+1,Tot,D,DONE);
			 break;		
		 }
	}
}
int main()
{
	cin.sync_with_stdio(false);
	cin>>m;
	for(int t = 1;t <= m;t++)
	{
		memset(f,0,sizeof(f));
		memset(d,0,sizeof(d));
		cin>>n;
		for(int i = 1;i <= n;i++) cin>>y1[i]>>x1[i]>>y2[i]>>x2[i]>>col[i];
		for(int i = 1;i <= n;i++)
	 	 for(int j = 1;j <= n;j++)
	  	  if(i - j)
	   	   if( y1[j] == y2[i] && jud(i,j) )
	   	   {
	      		f[i][j]=1;
	    		d[j]++;
	       }
	    ans=MAXN;
	    dfs(1,0,d,done);
	    cout<<ans-1<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值