POJ-1019 Number Sequence

34 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37441 Accepted: 10807

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest


#include <cstdio>
#include <cmath>
#include <iostream>
#define MAXN 2147483647
int num,tot,T,now;
long long f[31270],d[31270],ans[145240];
using namespace std;
int got(int x)
{
	int num = 0;
	while(x)
	{
		num++;
		x/=10;
	}
	return num;
}
void Insert(int x)
{
	int length = got(x);
	int l = length; 
	while(x)
	{
		ans[tot+length] = x%10;
		x/=10;
		length--;		
	}
	tot+=l;	
} 
int main()
{
	for(int i = 1;i;i++)
	{
		f[i] = f[i-1] + got(i);
		d[i] = f[i] + d[i-1];
		num++;
		if(d[i-1] >= MAXN) break;
	}
	for(int i = 1;i <= num;i++) 
	 Insert(i);
	cin>>T;
	for(int time = 1;time <= T;time++)
	{
		cin>>now;
		int s = 1,t = num;
		while(s != t)
		{
			int mid = (s+t)/2;
			if(d[mid-1]+1 <= now) s = mid+1;
			else t = mid;	
		}	
		s--;
		cout<<ans[now-d[--s]]<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值