Hdu-4749 Parade Show

Description


  2013 is the 60 anniversary of Nanjing University of Science and Technology, and today happens to be the anniversary date. On this happy festival, school authority hopes that the new students to be trained for the parade show. You should plan a better solution to arrange the students by choosing some queues from them preparing the parade show. (one student only in one queue or not be chosen)
  Every student has its own number, from 1 to n. (1<=n<=10^5), and they are standing from 1 to n in the increasing order the same with their number order. According to requirement of school authority, every queue is consisted of exactly m students. Because students who stand adjacent in training are assigned consecutive number, for better arrangement, you will choose in students with in consecutive numbers. When you choose these m students, you will rearrange their numbers from 1 to m, in the same order with their initial one.
  If we divide our students’ heights into k (1<=k<=25) level, experience says that there will exist an best viewing module, represented by an array a[]. a[i] (1<=i<=m)stands for the student’s height with number i. In fact, inside a queue, for every number pair i, j (1<=i,j<=m), if the relative bigger or smaller or equal to relationship between the height of student number i and the height of student number j is the same with that between a[i] and a[j], then the queue is well designed. Given n students’ height array x[] (1<=x[i]<=k), and the best viewing module array a[], how many well designed queues can we make at most?
 

Input

Multiple cases, end with EOF.
First line, 3 integers, n (1<=n<=10^5) m (1<=m<=n) k(1<=k<=25),
Second line, n students’ height array x[] (1<=x[i]<=k,1<=i<=n);
Third line, m integers, best viewing module array a[] (1<=a[i]<=k,1<=i<=m);
 

Output

One integer, the maximal amount of well designed queues.
 

Sample Input

    
    
10 5 10 2 4 2 4 2 4 2 4 2 4 1 2 1 2 1
 

Sample Output

  
  
1


题意&&分析:字符串匹配的一种变形,要求大小关系匹配上,把比较函数修改一下就可以了。


#include <map> 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
map <int,int> f;
int n,m,k,ans,s[100005],t[100005],l[100005],r[100005],jud[100005],Next[100005];
bool cmp(int x,int y)
{
	int d = y - x;
	if(jud[x] >= 0)
	{
		if(t[d + jud[x]] == t[y]) return true;
		else return false;
	}
	else
	{
		if(r[x] >= 0) if(t[d + r[x]] < t[y]) return false;
		if(l[x] >= 0) if(t[d + l[x]] > t[y]) return false;
		return true;
	}
}
int main()
{
	while(scanf("%d %d %d",&n,&m,&k) == 3)
	{
		f.clear();
		for(int i = 0;i < n;i++) scanf("%d",&t[i]);
		for(int i = 0;i < m;i++) jud[i] = l[i] = r[i] = -1;
		for(int i = 0;i < m;i++) 
		{
			scanf("%d",&s[i]);
			if(f.count(s[i])) jud[i] = f[s[i]];
			else 
			{
				map <int,int>::iterator Max = f.lower_bound(s[i]);
				if(Max != f.end()) r[i] = Max->second;
				if(Max != f.begin()) l[i] = (--Max)->second;
				f[s[i]] = i;
			}
		}
		memset(Next,0,sizeof(Next));
		int now = Next[0] = -1;
		for(int i = 1;i < m;i++)
		{
			while(now >= 0 && s[now+1] != s[i]) now = Next[now];
			if(s[now+1] == s[i]) now++;
			Next[i] = now;
		}
		now = -1,ans = 0;
		for(int i = 0;i < n;i++)
		{
			while(now >= 0 && !cmp(now+1,i)) now = Next[now];
			if(cmp(now+1,i)) now++;
			if(now == m-1)
			{
				now = -1;
				ans++;
			}
		}
		cout<<ans<<endl;
	}	
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值