Hdu-4348 To the moon(可持久化线段树)

Description

Background
To The Moon is a independent game released in November 2011, it is a role-playing adventure game powered by RPG Maker.
The premise of To The Moon is based around a technology that allows us to permanently reconstruct the memory on dying man. In this problem, we'll give you a chance, to implement the logic behind the scene.

You‘ve been given N integers A [1], A [2],..., A [N]. On these integers, you need to implement the following operations:
1. C l r d: Adding a constant d for every {A i | l <= i <= r}, and increase the time stamp by 1, this is the only operation that will cause the time stamp increase.
2. Q l r: Querying the current sum of {A i | l <= i <= r}.
3. H l r t: Querying a history sum of {A i | l <= i <= r} in time t.
4. B t: Back to time t. And once you decide return to a past, you can never be access to a forward edition anymore.
.. N, M ≤ 10 5, |A [i]| ≤ 10 9, 1 ≤ l ≤ r ≤ N, |d| ≤ 10 4 .. the system start from time 0, and the first modification is in time 1, t ≥ 0, and won't introduce you to a future state.

Input

n m
A 1 A 2 ... A n
... (here following the m operations. )

Output

... (for each query, simply print the result. )

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

2 4
0 0
C 1 1 1
C 2 2 -1
Q 1 2
H 1 2 1

Sample Output

4
55
9
15

0
1

分析:标记永久化节省空间。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstdio>
#include <set>
#include <map>
#include <vector>
#include <stack>
#include <cmath>
#include <queue>
#include <cstring>
#define MOD 1000000007
#define N 100005
using namespace std;
typedef long long ll;
int n,m,cnt,now,a[N],rt[2*N];
struct Tree
{
    int ls,rs;
    ll sum,lazy;
}tr[N*40];
void Build(int &node,int l,int r)
{
    node = ++cnt;
    tr[node].lazy = 0;
    if(l == r)
    {
        tr[node].sum = a[l];
        return;
    }
    int mid = (l+r) >> 1;
    Build(tr[node].ls,l,mid);
    Build(tr[node].rs,mid+1,r);
    tr[node].sum = tr[tr[node].ls].sum + tr[tr[node].rs].sum;
}
void deal(int &node,int x,int y,int d,int l,int r)
{
    tr[cnt+1] = tr[node];
    node = ++cnt;
    tr[node].sum += 1ll*(y-x+1)*d;
    if(x == l && y == r)
    {
        tr[node].lazy += d;
        return;
    }
    int mid = (l+r)>>1;
    if(y <= mid) deal(tr[node].ls,x,y,d,l,mid);
    else
     if(x <= mid)
     {
        deal(tr[node].ls,x,mid,d,l,mid);
        deal(tr[node].rs,mid+1,y,d,mid+1,r);
     }
     else deal(tr[node].rs,x,y,d,mid+1,r);
}
ll Find(int node,int x,int y,int l,int r)
{
    if(x == l && y == r) return tr[node].sum;
    int mid = (l+r)>>1;
    if(y <= mid) return tr[node].lazy*(y-x+1ll)+Find(tr[node].ls,x,y,l,mid);
    else
     if(x <= mid) return  tr[node].lazy*(y-x+1ll)+Find(tr[node].ls,x,mid,l,mid)+Find(tr[node].rs,mid+1,y,mid+1,r);
     else return tr[node].lazy*(y-x+1ll)+Find(tr[node].rs,x,y,mid+1,r);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cnt = 0;
        for(int i = 1;i <= n;i++) scanf("%d",&a[i]);
        now = 0;
        Build(rt[0],1,n);
        for(int i = 1;i <= m;i++)
        {
            char c[2];
            scanf("%s",c);
            if(c[0] == 'Q')
            {
                int l,r;
                scanf("%d%d",&l,&r);
                printf("%I64d\n",Find(rt[now],l,r,1,n));
            }
            if(c[0] == 'C')
            {
                int l,r,d;
                scanf("%d%d%d",&l,&r,&d);
                rt[now+1] = rt[now];
                deal(rt[++now],l,r,d,1,n);
            }
            if(c[0] == 'H')
            {
                int l,r,t;
                scanf("%d%d%d",&l,&r,&t);
                printf("%I64d\n",Find(rt[t],l,r,1,n));
            }
            if(c[0] == 'B') scanf("%d",&now);
        }
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值