ACM-ICPC国际大学生程序设计竞赛北京赛区(2017)网络赛 Agent Communication(图论)

185 篇文章 0 订阅
116 篇文章 0 订阅

描述

In Peking University, there are many homeless cats. The students of cat club built n nests and some paths for those cats. A path connects two nests directly. All nests are connected by paths and there is only one route between any two nests.

Li Lei is the chief of the cat club. He just got some donation for the cats. So he decides to build a new path which connects two nests to make cats travel more easily. He hopes that after the new path is built, the maximum distance between two nests becomes as short as possible. The distance between two nests is defined as the number of paths along the route between two nests.

Can you help Li Lei to figure out how to build the new path?

输入

The first line of input contains an integer t(t ≤ 50), the number of test cases. Then t test cases follow.

For each case:

The first line of input contains an integer n(n ≤ 1000), the number of nests.

Among the next n-1 lines, each line contains two integer x and y (1 ≤ x, y ≤ n), meaning that there is a path between the x-th nest and the y-th nest.

输出

For each test case, output one integer, the maximum distance of two nests after the new path is built correctly.

样例提示

case 1: build a path between 1 and 5

case 2: build a path between 3 and 5

样例输入
2
6
1 2
2 3
3 4
4 5
3 6
7
1 3
2 3
3 4
4 5
5 6
5 7
样例输出
3

3

分析:这是一道原题(hdu-5699货物运输),不过货物运输中给的是一条链.

链上解法见:http://blog.csdn.net/tc_to_top/article/details/51476095

现在给你的是一棵树,我们考虑树中的直径,可以证明最优解一定存在于直径上两点,所以我们可以先求出来任意一条直径,然后同货物运输。

#include<bits/stdc++.h>
using namespace std;
const int INF = 1e9 + 5;
const int N = 1005;
int n,Time,S,T,len,d[N],p[N],dis[N],length[N][N];
bool flag,vis[N];
vector<int> G[N];
void DIS(int u,int fa,int head,int deep)
{
	length[head][u] = deep;
	for(int v : G[u])
	 if(v != fa) DIS(v,u,head,deep+1);
}
void dfs(int u,int fa,int deep,int &t)
{
	if(deep > len)
	{
		len = deep;
		t = u;
	}
	for(int v : G[u])
	 if(v != fa) dfs(v,u,deep+1,t);
}
void dfs2(int u,int fa,int deep)
{
	d[deep] =  u;
	if(u == T) 
	{
		flag = true;
		return;
	}
	for(int v : G[u])
	 if(!flag && v != fa) dfs2(v,u,deep+1);
}
void dfs3(int u,int fa,int deep,int head)
{
	p[u] = head;
	dis[u] = deep;
	for(int v : G[u])
	 if(v != fa && !vis[v]) dfs3(v,u,deep+1,head);  
}
bool check(int mid)
{
	int ma1 = -INF,ma2 = -INF,mi1 = INF,mi2 = INF;
	for(int i = 1;i < n;i++)
	 for(int j = i+1;j <= n;j++)
	 {
		 if(length[i][j] <= mid) continue;
		 int x = i,y = j,temp = dis[i] + dis[j] + 1;
		 if(p[x] > p[y]) swap(x,y);
		 ma1 = max(p[x] + p[y] - (mid - temp),ma1);
		 ma2 = max(p[y] - p[x] - (mid - temp),ma2);
		 mi1 = min(p[x] + p[y] + mid - temp,mi1);
		 mi2 = min(p[y] - p[x] + mid - temp,mi2);
	 }
	if(mi1 < 0 || mi2 < 0) return false;
	if(ma1 > mi1 || ma2 > mi2) return false;
	if(mi1 < ma2) return false;
	if(ma1 == mi1 && ma2 == mi2 && ((ma1 + ma2) & 1)) return false;
	return true;  
}
int main()
{
	scanf("%d",&Time);
	while(Time--)
	{
		memset(vis,0,sizeof(vis));
		scanf("%d",&n);
		for(int i = 1;i <= n;i++) G[i].clear();
		for(int i = 1;i < n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			G[u].push_back(v);
			G[v].push_back(u);
		}
		for(int i = 1;i <= n;i++) DIS(i,0,i,0);
		len = 0;
		dfs(1,0,1,S);
		len = 0;
		dfs(S,0,1,T);
		flag = false;
		dfs2(S,0,1);
		for(int i = 1;i <= len;i++) vis[d[i]] = true;
		for(int i = 1;i <= len;i++) dfs3(d[i],0,0,i);
		int l = 0,r = n;
		while(l != r)
		{
			int mid = (l+r)>>1;
			if(check(mid)) r = mid;
			else l = mid+1;
		}
		cout<<l<<endl;
	}
}
/*/
2
6
1 2
2 3
3 4
4 5
3 6
7
1 3
2 3
3 4
4 5
5 6
5 7
/*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ACM-ICPC国际大学生程序设计竞赛)是一项全球性的大学生程序设计,每年吸引来自世界各地的顶尖大学代表队参与。ACM-ICPC竞赛的核心内容是团队编程和问题解决能力。 首先,ACM-ICPC竞赛对参选手的编程能力要求很高。参队伍需要在规定的时间内解决一系列的算法问题,这些问题常常包含复杂的数据结构和算法,要求选手在有限的时间内设计和实现高效的程序。 其次,ACM-ICPC竞赛强调团队协作。每个队伍由三名选手组成,他们需要分工合作,保持良好的沟通与协调,共同解决问题。团队成员需要相互理解、相互信任,快速地协商和决策,同时要保持高效的任务分配和时间管理。 此外,ACM-ICPC竞赛也需要选手具备良好的问题解决能力。这些问题往往是实际应用或理论推导相关的,选手需要从数学、计算机科学和算法等多个角度出发,找到最佳解决方案。在面对问题时,选手需要对问题进行分析、抽象和建模,运用各种算法和数据结构进行解决。 对于参选手来说,ACM-ICPC提供了一个学习与交流的平台。在比中,选手可以接触到不同国家和地区的优秀程序设计人才,学习他们的思维方式和编程技巧。同时,ACM-ICPC还举办了一系列的培训和研讨会,让选手有机会深入了解计算机科学和算法领域最新的研究成果。 总之,ACM-ICPC国际大学生程序设计竞赛是一个挑战性与学习性兼具的比。它要求选手具备扎实的编程技能、团队合作能力和问题解决能力。参与此竞赛不仅可以锻炼自己的编程能力,还能与全球的顶尖程序设计人才进行交流,拓宽自己的视野和思维方式。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值