poj2367Genealogical tree

题目链接:

点我点我

题目:

Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2704 Accepted: 1816 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source


这个题目是拓扑排序的入门题。。

首先在这里一个讲的非常好的链接:

传送门点我点我

我用了两种方法做这个题。

第一种是利用入度为0的点必然是前面的点,然后删除从这个点到其他点的边,最后一期输出结果。。速度很快。

第二种是利用dfs搜索,直到搜索到已经访问到的点,然后利用栈来保存。。最后利用栈的性质来输出即可。。

第二中代码为:

#include<cstdio>
#include<iostream>
#include<stack>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=100+10;
int vis[maxn],map[maxn][maxn];
int n,t;
stack<int>S;
bool dfs(int u)
{
    vis[u]=-1;
    for(int v=1;v<=n;v++)
     if(map[u][v])
    {
       // if(vis[v]<0)  return false;
         if(!vis[v]&&!dfs(v))  return false;
    }
    vis[u]=1;
    S.push(u);
    return true;
}


bool toposort()
{
    memset(vis,0,sizeof(vis));
    for(int u=1;u<=n;u++)
      {
        if(!vis[u])
        {
          if(!dfs(u))
            return false;
        }
     }
     return true;
}


int main()
{
    int u;
    bool ok;
    while(scanf("%d",&n)!=EOF)
    {
        t=n;
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
            {
                while(1)
                {
                    scanf("%d",&u);
                    if(u==0)
                        break;
                    map[i][u]=1;
                }
            }
        ok=toposort();
        if(ok)
        {
        while(!S.empty())
           {
               int val=S.top();
               if(t!=1)
                  printf("%d ",val);
               else
                  printf("%d\n",val);
               S.pop();
               t--;
           }
        }
    }
    return 0;
}


第一种方法代码:

#include<cstdio>
#include<cstring>
const int maxn=100+10;
int map[maxn][maxn],into[maxn],ans[maxn],vis[maxn];
int pos;
int main()
{
    int n,u,temp;
    while(~scanf("%d",&n))
    {
        pos=0;
        memset(map,0,sizeof(map));
        memset(into,0,sizeof(into));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            while(1)
            {
                scanf("%d",&u);
                if(u==0)
                  break;
                map[i][u]=1;
            }
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            if(map[i][j])
                into[j]++;
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            if(into[j]==0&&!vis[j])
              {
                temp=j;
                vis[j]=1;
                ans[pos++]=temp;
                for(int m=1;m<=n;m++)
                 {
                   if(map[temp][m])
                       into[m]--;
                 }
              }
        }
        for(int i=0;i<pos;i++)
        {
            if(i!=pos-1)
                printf("%d ",ans[i]);
            else
                printf("%d\n",ans[i]);
        }
    }
    return 0;
}


第三种方法是 相当于训练一下stl吧

用两个队列来完成,第一个队列是最后输出答案的时候用。。

第二个是保存入度为0的点。。不过意料之中的是时间非常慢。。

代码为:

#include<cstdio>
#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
const int maxn=100+10;
vector<int>vec[maxn];
int n;
int in[maxn];
queue<int>ans;
queue<int>Q;
int topo()
{
    int sum=0;
    int top;
    for(int i=1;i<=n;i++)
    {
        if(in[i]==0)
            Q.push(i);
    }
    while(!Q.empty())
    {
        int top=Q.front();
        Q.pop();
        ans.push(top);
        for(int i=0;i<vec[top].size();i++)
        {
            if(--in[vec[top][i]]==0)
               Q.push(vec[top][i]);
        }
    }
    while(!ans.empty())
    {
        sum++;
        int temp=ans.front();
        ans.pop();
        if(sum!=n)
            printf("%d ",temp);
        else
            printf("%d\n",temp);
    }
}

void read_graph()
{
    int u;
    for(int i=1;i<=n;i++)
    {
        vec[i].clear();
        in[i]=0;
    }
    for(int i=1;i<=n;i++)
        {
            while(1)
            {
                scanf("%d",&u);
                if(u==0)
                    break;
                vec[i].push_back(u);
                in[u]++;
            }
        }
}

int main()
{
    while(~scanf("%d",&n))
    {
        read_graph();
        topo();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值