poj1157LITTLE SHOP OF FLOWERS

题目链接:

点我点我

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17783 Accepted: 8202

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source



这个题目是动态规划题。。

dp[i][j]表示前i盆花放在第j的位置的得到的最大价值。

则状态转移方程为

dp[i+1][j]=max(dp[i+1][j],dp[i][j]+map[i+1][j];

因为要打印路劲,所以从0开始递推。然后再状态转移方程里记录路径。。

最后递归打印路径。

代码为:

#include<cstdio>
#include<cstring>
#include<iostream>
#define INF 0x3f3f3f3f
const int maxn=100+10;
using namespace std;
int dp[maxn][maxn],map[maxn][maxn],pre_x[maxn][maxn],pre_y[maxn][maxn];
int n,m,last;

int solve()
{
    memset(dp,-INF,sizeof(dp));
    int temp=dp[0][0];
    dp[0][0]=0;
    for(int i=0;i<n;i++)//枚举第i盆花
        for(int j=i;j<=m;j++)//枚举第i盆花放的位置
        {
            if(dp[i][j]==temp)  continue;
            for(int k=j+1;k<=m;k++)//枚举下一盆花放的位置
            {
                if(dp[i+1][k]<dp[i][j]+map[i+1][k])
                {
                    dp[i+1][k]=dp[i][j]+map[i+1][k];
                    pre_x[i+1][k]=i;
                    pre_y[i+1][k]=j;
                 //   cout<<i+1<<"前面"<<j<<endl;
                }
            }
        }
     int ans=-INF;
     for(int i=n;i<=m;i++)
     {
         if(dp[n][i]>ans)
         {
             ans=dp[n][i];
             last=i;
         }
     }
     return ans;
}

void print(int x,int y)
{
    if(x==1)
    {
        printf("%d",y);
        return;
    }
    print(pre_x[x][y],pre_y[x][y]
    printf(" %d",y);
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        int ans=solve();
        printf("%d\n",ans);
        print(n,last);
        printf("\n");
    }
    return 0;
}
/*
3 5
-50 -50 -50 -50 -50
-50 -50 -50 -50 -50
-50 -50 -50 -50 -50
*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值