POJ2456 Aggressive cows(二分搜索)

题目链接:http://poj.org/problem?id=2456


Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6524 Accepted: 3267

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.


题意:有n间牛舍,排成一条直线,位置分别为xi。有m头牛脾气很大,为了防止这些牛互相伤害,所以要求这些牛的牛舍距离尽可能远。求出这些牛所在牛舍之间距离的最大值。


很容易看出只需要安排这m头牛就可以了。要求他们之间的距离最大,可以二分距离记为c,然后从距离最近的牛舍开始,安排距离大于c的牛舍住,如果安排不下,则说明距离太大,二分左半部分,否则二分右半部分。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

#define inf 0x3f3f3f3f

int n,m;
int x[100005];

int main()
{
	while (scanf("%d%d",&n,&m)!=EOF)
	{
		for (int i=0;i<n;i++)
		{
			scanf("%d",&x[i]);
		}
		sort(x,x+n);//记得首先要排序
		int head=0,tail=inf;
		while (tail-head>1)//二分的结束判定,由于是整数所以小于1就可以结束了
		{
			bool flag=1;
			int mid=(head+tail)/2;
			int la=0;
			for (int i=1;i<m;i++)
			{
				int c=la+1;
				while (c<n&&x[c]-x[la]<mid)
					++c;
				if (c==n) {flag=0;break;}
				la=c;
			}
			if (flag) head=mid;else tail=mid;
		}
		printf("%d\n",head);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值