2014上海全国邀请赛 j 题!!

Comparison of Android versions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B. The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat). The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch. The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010. Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity. Please develop a program to compare two Android build numbers.
 

Input
  
  
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process. Each test case consists of a single line containing two build numbers, separated by a space character.
 

Output
  
  
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows: ● Print "<" if the release of the first build number is lower than the second one; ● Print "=" if the release of the first build number is same as he second one; ● Print ">" if the release of the first build number is higher than the second one. Continue to output the result of date comparison as follows: ● Print "<" if the date of the first build number is lower than the second one; ● Print "=" if the date of the first build number is same as he second one; ● Print ">" if the date of the first build number is higher than the second one. If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
 

Sample Input
  
  
2 FRF85B EPF21B KTU84L KTU84M
 

Sample Output
  
  
Case 1: > > Case 2: = <
 


看完题目我才发现英语是多么的重要!!!!!!

以后好好学英语~~~~(>_<)~~~~ 

题意:比较版本发行的大小和时间的大小;

思路:比较版本时就比较第一个字母就ok了;

比较时间时还要判断是否是in the same code branch (就是看第二个字母是否相同);之前看的时候差点晕死了:-(

相同就多比较最后一个字母,不相同就不比较最后一个字母;

很奇怪是吧,好像这场比赛题目都这么奇怪:-O

AC代码(写的比较挫。。):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
	char str1[10], str2[10], ans1, ans2;
	int T;
	scanf("%d", &T);
	for(int k=1; k<=T; k++)
	{
		int a, b;
		char s1[10], s2[10];
		scanf("%s %s", str1, str2);
		if(str1[0]>str2[0]) ans1='>';
		else if(str1[0]==str2[0]) ans1='=';
		else if(str1[0]<str2[0]) ans1='<';
		sscanf(str1+3, "%d", &a); sscanf(str2+3, "%d", &b);
		if(str1[2]>str2[2]) ans2='>';
		else if(str1[2]<str2[2]) ans2='<';
		else if(str1[2]==str2[2]) {
			if(a>b)ans2='>';
			else if(a<b)ans2='<';
			else if(a==b && str1[1]!=str2[1]) ans2='=';
			else if(a==b && str1[1]==str2[1]){
				if(str1[5]>str2[5]) ans2='>';
				else if(str1[5]<str2[5]) ans2='<';
				else if(str1[5]==str2[5]) ans2='=';
			}
		}
		printf("Case %d: %c %c\n", k, ans1, ans2);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值